Bug 1554304 - Sound really low volume on Thinkpad T570
Summary: Sound really low volume on Thinkpad T570
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-12 11:59 UTC by Ferry Huberts
Modified: 2018-12-14 20:41 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 17:04:09 UTC


Attachments (Terms of Use)
Output of alsa-info.sh on 4.15.3 (42.10 KB, text/plain)
2018-11-26 23:12 UTC, Tim Van den Eynde
no flags Details
Output of alsa-info.sh on 4.19.4 (41.95 KB, text/plain)
2018-11-26 23:13 UTC, Tim Van den Eynde
no flags Details
Revert Thinkpad dock patch (4.94 KB, patch)
2018-11-27 15:50 UTC, Jeremy Cline
no flags Details | Diff

Description Ferry Huberts 2018-03-12 11:59:30 UTC
Description of problem:
Since a few weeks or so (don't know how long) the sound output volume of the 
laptop speakers is really low, even when at maximum volume. I compared it to the windows 10 install on the machine and the volume there is much louder and seems correct, the way it is supposed to be and the way I remember it.

Version-Release number of selected component (if applicable):
4.15.6-300.fc27.x86_64

How reproducible:
always

Steps to Reproduce:
1. adjust sound volume and play sound
2.
3.

Actual results:


Expected results:


Additional info:
I tried adjusting all the setting, through the alsa mixer, through the pulseaudio mixer, nothing works. It seems as though an amp is not switched on in the hardware since plugging in the power also makes a sound that is very low in volume and not at all like it was before.

T570 BIOS 1.30

Comment 1 Ferry Huberts 2018-05-06 12:59:28 UTC
How do I disable Intel sound power management, to test whether that is the problem?

It worked ok before: early through halfway into Fedora 27 it worked just fine, then near the release of Fedora 28 is stopped working on Fedora 27. And it doesn't work properly on F28 either.

Most of the time it doesn't work properly, but very rarely it works just fine after coming out of suspend.

Comment 2 Jeremy Cline 2018-05-23 19:17:22 UTC
Hi Ferry,

Booting with "snd_hda_intel.power_save=0" disables power saving, but it's currently configured to be off in Fedora 27 so I don't think that's it. Since it worked previously and is easy to reproduce, bisecting[0] the kernel should pin-point the problem.

[0] https://docs.fedoraproject.org/quick-docs/en-US/kernel/troubleshooting.html#bisecting-the-kernel

Comment 3 Ferry Huberts 2018-05-23 20:10:27 UTC
that is a bit too large a bisect. it worked under f27 but not so much under f28.

it tends to work a bit better with the current kernel but I still can't put my finger on it when it fails and when not.

Comment 4 Ferry Huberts 2018-06-22 19:26:04 UTC
and with the current kernel 4.16.15-300.fc28.x86_64 it's a lot worse again. now I can almost never get it to do the right thing.

Comment 5 Justin M. Forbes 2018-07-23 15:09:36 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.

Fedora 28 has now been rebased to 4.17.7-200.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 6 Ferry Huberts 2018-07-23 15:15:49 UTC
issue still present.

I now have a trick.
when a youtube video has the really low volume problem, then I pause it, start a different youtube video, and if it doesn't have the problem, then I unpause the first one that had the problem ( and now no longer has the problem) and then pause the second video

Comment 7 Shane Maynard 2018-08-09 01:06:01 UTC
I also have this issue, Lenovo T570 with latest Fedora 28 updates as of Aug 8th. My Lenovo X1 Carbon (1st gen) also has the same issue after changing from a linux mint install to fedora 28.

Comment 8 Laura Abbott 2018-10-01 21:20:50 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.
 
Fedora 28 has now been rebased to 4.18.10-300.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 29, and are still experiencing this issue, please change the version to Fedora 29.
 
If you experience different issues, please open a new bug report for those.

Comment 9 Ferry Huberts 2018-10-15 11:22:26 UTC
alas, the issue is still present on f28, kernel-4.18.12-200.fc28.x86_64

Comment 10 Patryk Szalanski 2018-10-30 13:47:56 UTC
Still present on f28, 4.18.16-200.fc28.x86_64

Comment 11 Tim Van den Eynde 2018-11-24 00:40:51 UTC
I am an Arch user who stumbled upon this bug. I can confirm the regression happened somewhere between 4.15.3 and 4.15.5; assuming that those versions match.

I am willing to create a new partition and install Red Hat or Fedora on it, if it helps with debugging.

Comment 12 Jeremy Cline 2018-11-26 14:57:29 UTC
Can you run alsa-info.sh and attach the results? In Fedora it's provided by alsa-utils, it's probably the same package in Arch.

Comment 13 Tim Van den Eynde 2018-11-26 23:12:17 UTC
Created attachment 1508684 [details]
Output of alsa-info.sh on 4.15.3

Comment 14 Tim Van den Eynde 2018-11-26 23:13:04 UTC
Created attachment 1508685 [details]
Output of alsa-info.sh on 4.19.4

Comment 15 Jeremy Cline 2018-11-27 15:48:34 UTC
Thanks Tim!

I see a likely culprit in 4.15.5 (commit 61fcf8ece9b6b09450250c4ca40cc3b81a96a68d upstream). Can folks test https://koji.fedoraproject.org/koji/taskinfo?taskID=31144584 when it's done building to see if that "fixes" the problem?

Tim, if you'd prefer to build a kernel for Arch rather than install Fedora, I'll attach the revert patch since it doesn't revert cleanly.

Comment 16 Jeremy Cline 2018-11-27 15:50:26 UTC
Created attachment 1508938 [details]
Revert Thinkpad dock patch

Comment 17 Ferry Huberts 2018-11-27 18:51:18 UTC
Wow, this seems to work a lot better on my T570. Been testing out some youtube videos and sound seems to be ok again. Been 10 minutes though. I'll continue to run this kernel for a few days to see if it's really fixed.

Comment 18 Jeremy Cline 2018-11-27 19:23:36 UTC
Thanks for testing that, Ferry. I just reverted a patch that I guessed caused the regression, so I'll still need to come up with a real fix. I may or may not get as far as that today, though.

Comment 19 Jeremy Cline 2018-11-29 19:42:27 UTC
Okay, so I dug into this a little bit.

The patch that caused the regression was to fix the mic and headphone jack[0] on the T470 dock (and it seems like the same dock works with the T570).

Does anyone have a dock, and if so, does the headphone jack on it actually work?


[0] https://bugzilla.kernel.org/show_bug.cgi?id=195161

Comment 20 Jeremy Cline 2018-11-29 21:41:58 UTC
Ferry, would you mind testing https://koji.fedoraproject.org/koji/taskinfo?taskID=31184179 as well? Thanks.

Comment 21 Ferry Huberts 2018-11-29 21:43:12 UTC
will do this weekend

Comment 22 Ferry Huberts 2018-11-30 12:35:31 UTC
ok, first test, with kernel 4.19.4-300.rhbz1554304.fc29.x86_64 (the first koji build): Thinkpad Ultra Dock 3.5mm audio out does NOT work, speakers just turn off when docking and turn back on again when undocking.

Comment 23 Ferry Huberts 2018-11-30 12:42:26 UTC
second test, with kernel 4.19.5-300.bz1554304.fc29.x86_64 (the second koji build): sound is back to 'broken' state, but Thinkpad Ultra Dock 3.5mm audio out does work again. Going to uninstall this one

Comment 24 Jeremy Cline 2018-12-01 18:02:40 UTC
Third time is (hopefully) the charm. Upstream has a potential fix, can folks test out https://koji.fedoraproject.org/koji/taskinfo?taskID=31218204 when it finishes?

Comment 25 Ferry Huberts 2018-12-02 15:53:23 UTC
(In reply to Jeremy Cline from comment #24)
> Third time is (hopefully) the charm. Upstream has a potential fix, can folks
> test out https://koji.fedoraproject.org/koji/taskinfo?taskID=31218204 when
> it finishes?

That one seems to be really good: sound on my T570 works like it should and the audio out on the ultra dock also works as it should. docked and undocked a few times and works like a charm. I like that kernel.

Finally the sound issue is fixed!
Only took 9 months ;-)

Comment 26 Fedora Update System 2018-12-06 14:33:56 UTC
kernel-tools-4.19.7-200.fc28 kernel-headers-4.19.7-200.fc28 kernel-4.19.7-200.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a0914af224

Comment 27 Fedora Update System 2018-12-06 14:34:32 UTC
kernel-tools-4.19.7-300.fc29 kernel-headers-4.19.7-300.fc29 kernel-4.19.7-300.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5904d0794d

Comment 28 Fedora Update System 2018-12-07 03:16:10 UTC
kernel-4.19.7-300.fc29, kernel-headers-4.19.7-300.fc29, kernel-tools-4.19.7-300.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5904d0794d

Comment 29 Fedora Update System 2018-12-07 03:22:42 UTC
kernel-4.19.7-200.fc28, kernel-headers-4.19.7-200.fc28, kernel-tools-4.19.7-200.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a0914af224

Comment 30 Randy Barlow 2018-12-11 17:04:09 UTC
A Fedora update associated with this bug has been pushed to the stable repository.

Comment 31 Ferry Huberts 2018-12-11 19:45:41 UTC
@jeremy

You can't imagine how happy I am that this is now fixed!
Huge huge thanks for picking this one up and fixing it!

Comment 32 Randy Barlow 2018-12-14 20:41:19 UTC
A Fedora update associated with this bug has been pushed to the stable repository.


Note You need to log in before you can comment on or make changes to this bug.