Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1554345 - Service systemd-hibernate-resume x2dswap fails in qemu VM
Service systemd-hibernate-resume x2dswap fails in qemu VM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
28
ppc64le Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Vendula Poncova
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PPCTracker
  Show dependency treegraph
 
Reported: 2018-03-12 09:48 EDT by Menanteau Guy
Modified: 2018-04-09 09:26 EDT (History)
24 users (show)

See Also:
Fixed In Version: anaconda-28.22.3-1 anaconda-28.22.3-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-09 09:26:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs of an openqa test in error (842.37 KB, application/x-gzip)
2018-03-12 09:49 EDT, Menanteau Guy
no flags Details

  None (edit)
Description Menanteau Guy 2018-03-12 09:48:19 EDT
In openQA tests for F28 in ppc64le arch with Fedora-Server-dvd-ppc64le-28-20180310.n.0.iso, the test that checks whether any services tried to start up  fails because of systemd-hibernate-resume@dev-mapper-fedora\x2dswap.service

After a fresh install, at reboo, the test run the "systemctl --failed" command
 and gets:
● systemd-hibernate-resume@dev-mapper-fedora\x2dswap.service loaded failed failed Resume from hibernation using device /dev/mapper/fedora-swap

Note that I reproduced it manually (without openqa) and I didn't do any hibernate, after the fresh install. just click on "reboot" of the VNC installation panel and VM start again.

in journalctl we have:
localhost.localdomain systemd[1]: Starting Resume from hibernation using device /dev/mapper/fedora-swap...
localhost.localdomain systemd-hibernate-resume[461]: Failed to write '253:1' to /sys/power/resume: Permission denied
localhost.localdomain systemd[1]: systemd-hibernate-resume@dev-mapper-fedora\x2dswap.service: Main process exited, code=exited, status=1/FAILURE
localhost.localdomain systemd[1]: systemd-hibernate-resume@dev-mapper-fedora\x2dswap.service: Failed with result 'exit-code'.
localhost.localdomain systemd[1]: Failed to start Resume from hibernation using device /dev/mapper/fedora-swap.
localhost.localdomain audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=systemd-hibernate-resume@dev-mapper-fedora\x2dswap comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'

The problem is present on ppc64 big endian an little endian.

I assign this bug to "anaconda" component because I am not sure we should have "Starting Resume from hibernation" without doing any hibernation. Feel free to re-assign it to another component if you think anaconda is not concerned.
Comment 1 Menanteau Guy 2018-03-12 09:49 EDT
Created attachment 1407180 [details]
logs of an openqa test in error
Comment 2 Vendula Poncova 2018-03-13 09:15:05 EDT
In anaconda, we have recently added the resume option to enable the hibernation (see the bug #1206936). We can exclude ppc64, if that is the correct fix for this bug. However, it would be good to hear an opinion from the kernel developers. Reassigning.
Comment 3 Laura Abbott 2018-03-13 10:57:21 EDT
$ cat configs/fedora/generic/powerpc/CONFIG_HIBERNATION
# CONFIG_HIBERNATION is not set

This is intentionally disabled on powerpc
Comment 4 Vendula Poncova 2018-03-14 08:23:44 EDT
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1393
Comment 5 Fedora Update System 2018-04-05 12:23:13 EDT
anaconda-28.22.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9fd9270cd5
Comment 6 Fedora Update System 2018-04-06 14:55:21 EDT
anaconda-28.22.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9fd9270cd5
Comment 7 Fedora Update System 2018-04-06 15:38:48 EDT
anaconda-28.22.3-1.fc28 initial-setup-0.3.56-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9fd9270cd5
Comment 8 Fedora Update System 2018-04-07 20:02:37 EDT
anaconda-28.22.3-1.fc28, initial-setup-0.3.56-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9fd9270cd5
Comment 9 Fedora Update System 2018-04-09 09:26:14 EDT
anaconda-28.22.3-1.fc28, initial-setup-0.3.56-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.