Bug 1554377 - chosen CPU is not supported when updating default cluster
Summary: chosen CPU is not supported when updating default cluster
Keywords:
Status: CLOSED DUPLICATE of bug 1585990
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.2.0
Hardware: x86_64
OS: Linux
medium
urgent vote
Target Milestone: ovirt-4.2.5
: ---
Assignee: Nobody
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-12 15:00 UTC by Dafna Ron
Modified: 2018-06-12 11:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-12 11:27:24 UTC
oVirt Team: Virt
michal.skrivanek: ovirt-4.2?
rule-engine: blocker?
dron: planning_ack?
dron: devel_ack?
dron: testing_ack?


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 89005 master MERGED db: setting cluster cpu_name,emulated_machine... 2018-03-15 09:15:41 UTC
oVirt gerrit 89035 ovirt-engine-4.2 MERGED db: setting cluster cpu_name,emulated_machine... 2018-03-15 10:53:24 UTC
oVirt gerrit 89051 ovirt-engine-4.1 MERGED db: setting cluster cpu_name,emulated_machine... 2018-03-26 12:52:38 UTC
oVirt gerrit 89610 ovirt-engine-4.1.10.z MERGED db: setting cluster cpu_name,emulated_machine... 2018-03-29 13:48:56 UTC

Description Dafna Ron 2018-03-12 15:00:51 UTC
Description of problem:

we are failing ost test 002_bootstrap.update_default_cluster with error: 
Fault reason is "Operation Failed". Fault detail is "[Cannot edit Cluster. The chosen CPU is not supported.]". HTTP response code is 400.

Version-Release number of selected component (if applicable):

4.2

How reproducible:


Steps to Reproduce:
1. run ost with lago on 4.2 master suite (./run_suite basic_suite_master)
2.
3.

Actual results:

we fail  test 002_bootstrap.update_default_cluster

Expected results:

we should succeed.


Additional info:

logs located here: 

http://jenkins.ovirt.org/job/ovirt-4.2_change-queue-tester/1181/artifact/exported-artifacts/basic-suit-4.2-el7/test_logs/basic-suite-4.2/post-002_bootstrap.py/

Comment 1 Yaniv Kaul 2018-03-13 07:12:50 UTC
Michal - this is happening when trying to update the Cluster CPU to PPC.

Comment 2 Yaniv Kaul 2018-03-15 13:10:42 UTC
Raz, please see if it reproduces on 4.1.
The test is simple - change the CPU of a non-active cluster (with no hosts, etc.) from X86 to PPC.

Comment 3 Raz Tamir 2018-03-15 13:31:48 UTC
Tested on rhevm-4.1.10.3-0.1.el7.noarch

Edited CPU arch from x86_64 to PPC - Pass

Comment 4 Michal Skrivanek 2018-03-16 15:45:20 UTC
(In reply to Raz Tamir from comment #3)
> Tested on rhevm-4.1.10.3-0.1.el7.noarch
> 
> Edited CPU arch from x86_64 to PPC - Pass

that was probably not tested using API, was it? With the infra changes merged to 4.1 it's supposed to fail the same way as it did on 4.2 and master

Comment 5 Lukas Svaty 2018-04-19 07:54:29 UTC
Reproduced in automation on the upgraded engine from 4.1 to 4.2.
When updating version of Default (not initialized) cluster form 4.1 to 4.2

Test Name: rhv_upgrade.common_upgrade_test.TestUpgradeCommon.test_upgrade_clusters
Test Description: This tests upgrades all clusters to latest versions
Iteration number: 4
Update cluster Default with {'version': '4.2'}
Using Correlation-Id: clusters_update_71179464-6f42-4bd7
Failed to update element NOT as expected:
	Status: 400
	Reason: Bad Request
	Detail: [Cannot edit Cluster. The chosen CPU is not supported.]

Response code is not valid, expected is: [200, 201], actual is: 400 
Failed to update cluster default with {'version': '4.2'}

Assing Automation, Automation Blocker, and Regression - found in automation, blocking upgrade tests, regression as test-cases passed in previous runs.

Comment 7 Red Hat Bugzilla Rules Engine 2018-05-02 10:19:51 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 8 Michal Skrivanek 2018-06-12 11:27:24 UTC
this is the same failure as discussed in bug 1585990
(this bug was reported quite a lot earlier but the other one has more details and tracks the actual fix, so closing it this way)

*** This bug has been marked as a duplicate of bug 1585990 ***


Note You need to log in before you can comment on or make changes to this bug.