Bug 1554444 - OSP13 Deployment with TLS everywhere fails - Compute nodes request neutron cert and fail
Summary: OSP13 Deployment with TLS everywhere fails - Compute nodes request neutron ce...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Emilien Macchi
QA Contact: Pavan
URL:
Whiteboard:
Depends On:
Blocks: encrypt_vnc_traffic 1507888
TreeView+ depends on / blocked
 
Reported: 2018-03-12 16:48 UTC by Prasanth Anbalagan
Modified: 2018-06-27 13:37 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180326192239.e59fd2c.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:36:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1754363 None None None 2018-03-14 09:43:51 UTC
OpenStack gerrit 551433 None MERGED Fixes certificate generation error for Neutron agents 2020-07-29 20:39:10 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:37:23 UTC

Description Prasanth Anbalagan 2018-03-12 16:48:31 UTC
Description of problem:
=======================

https://bugs.launchpad.net/tripleo/+bug/1754363

While trying to deploy TLS everywhere, given that we set the neutron cert specs in the neutron-base yaml, every node tries to request a certificate for neutron. However, not all neutron services output metadata_settings that would actually create a service principal that enables the usage of that cert. Hence, when we deploy, we get the following error:

            "Error: /Stage[main]/Tripleo::Certmonger::Neutron/Certmonger_certificate[neutron]: Could not evaluate: Could not get certificate: Server at https://freeipa-0.redhat.local/ipa/xml denied our request, giving up: 2100 (RPC failed at server. Insufficient access: Insufficient 'add' privilege to add the entry '<email address hidden>,cn=services,cn=accounts,dc=redhat,dc=local'.).",
            "Warning: /Stage[main]/Tripleo::Certmonger::Neutron/File[/etc/pki/tls/certs/neutron.crt]: Skipping because of failed dependencies",
            "Warning: /Stage[main]/Tripleo::Certmonger::Neutron/File[/etc/pki/tls/private/neutron.key]: Skipping because of failed dependencies",
            "Warning: /Stage[main]/Tripleo::Certmonger::Ca::Crl/File[tripleo-ca-crl]: Skipping because of failed dependencies",
            "Warning: /Stage[main]/Tripleo::Certmonger::Ca::Crl/Exec[tripleo-ca-crl-process-command]: Skipping because of failed dependencies",
            "Warning: /Stage[main]/Tripleo::Certmonger::Ca::Crl/Cron[tripleo-refresh-crl-file]: Skipping because of failed dependencies"


Version-Release number of selected component (if applicable):


How reproducible:
=================

Always

Comment 16 errata-xmlrpc 2018-06-27 13:36:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.