Bug 1554518 - Azure load balancer does not create
Summary: Azure load balancer does not create
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.10.0
Assignee: Ben Bennett
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-12 20:32 UTC by Ryan Cook
Modified: 2018-12-28 02:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The documentation for how to create an Azure LB was incomplete. Consequence: You could not make a working LB on Azure by following the docs. Fix: The docs were corrected to add the missing steps. Result: Azure LB creation is now correctly documented.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:10:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:11:12 UTC
Github openshift openshift-docs pull 8330 None None None 2018-04-12 15:44:58 UTC

Description Ryan Cook 2018-03-12 20:32:29 UTC
Description of problem: When attempting to create a load balancer similar to how one is created in the online documentation and on other cloud providers the load balancer never successfully finishes.


Version-Release number of selected component (if applicable):
3.7 and 3.9

How reproducible:
Create a deployment, add azure.conf, restart services


Steps to Reproduce:
1. deploy openshift
2. configure for azure
3. create load balancer svc

Actual results:
No load balancer created and svc stays in a pending state


Expected results:
Load balancer created


Additional info:

Comment 1 Ryan Cook 2018-03-13 14:49:15 UTC
@ben this can be resolved if the ga docs include the following

tenantId: <value>
subscriptionId: <value>
aadClientId: <value>
aadClientSecret: <null>
aadTenantId: <value>
resourceGroup: <value>
cloud: <value> 
location: <value>
vnetName: <value>
securityGroupName: <value>
primaryAvailabilitySetName: <value>


The above ^^ can create load balancers in 3.9

Comment 2 Ben Bennett 2018-04-12 15:44:59 UTC
This was fixed by https://github.com/openshift/openshift-docs/pull/8550

(Thanks for the PR @Ryan)

Comment 3 Meng Bo 2018-05-03 10:45:42 UTC
The document has been updated according to the comment#1

Set the bug as verified.

Comment 5 errata-xmlrpc 2018-07-30 19:10:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.