Bug 1554528 - Failed to validate power driver interface for node <uuid>. Error: %(prop)s is not set either in the configuration orin the node's driver_info
Summary: Failed to validate power driver interface for node <uuid>. Error: %(prop)s is...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic-staging-drivers
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Julia Kreger
QA Contact: mlammon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-12 21:33 UTC by mlammon
Modified: 2018-06-27 13:37 UTC (History)
4 users (show)

Fixed In Version: openstack-ironic-staging-drivers-0.9.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:36:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 552463 None MERGED Fix ovirt property error logging 2020-07-22 20:24:44 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:37:23 UTC

Description mlammon 2018-03-12 21:33:33 UTC
Failed to validate power driver interface for node <uuid>. Error: %(prop)s is not set either in the configuration orin the node's driver_info

Description:
We are not getting proper error printed in this situation when credentials in driver_info are either incorrect or missing

Environment:
openstack-ironic-staging-drivers-0.9.0-0.20180220235748.de59d74.el7ost.noarch
openstack-tripleo-common-8.4.1-0.20180224032817.d51ed49.el7ost.noarch
instack-undercloud-8.2.1-0.20180228034814.945b1d0.el7ost.noarch
openstack-ironic-conductor-10.1.2-0.20180223164019.4c3a611.el7ost.noarch
openstack-ironic-api-10.1.2-0.20180223164019.4c3a611.el7ost.noarch
openstack-ironic-inspector-7.2.0-0.20180217115157.a8d621f.el7ost.noarch



Steps to Reproduce:
1) Install openstack-ironic-conductor and its dependencies 
sudo easy_install pip
sudo yum install -y gcc python-devel libxml2-devel libcurl-devel
sudo pip install ovirt-engine-sdk-python
sudo systemctl restart openstack-ironic-conductor

2) Configure staging-ovirt driver in /etc/ironic/ironic.conf & restart conductor
Updated these entries
enabled_hardware_types=redfish,ipmi,idrac,ilo,staging-ovirt
enabled_management_interfaces=redfish,ilo,idrac,ipmitool,fake,staging-ovirt
enabled_power_interfaces=redfish,ilo,idrac,ipmitool,fake,staging-ovirt

sudo systemctl restart openstack-ironic-conductor

3) Import nodes
openstack overcloud node import ~/instackenv.json

4) Introspect

5) Try and change from enroll to manage
openstack baremetal node manage $(openstack baremetal node show osp13-controller1 -f value -c uuid)

You will see last_error (below)

(undercloud) [stack@undercloud-new ~]$ ironic node-show osp13-controller1
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+------------------------+-----------------------------------------------------------------------+
| Property               | Value                                                                 |
+------------------------+-----------------------------------------------------------------------+
| boot_interface         | pxe                                                                   |
| chassis_uuid           | None                                                                  |
| clean_step             | {}                                                                    |
| console_enabled        | False                                                                 |
| console_interface      | no-console                                                            |
| created_at             | 2018-03-12T15:19:29+00:00                                             |
| deploy_interface       | iscsi                                                                 |
| driver                 | staging-ovirt                                                         |
| driver_info            | {u'ovirt_vm_name': u'osp13-controller1', u'deploy_kernel':            |
|                        | u'48240453-c945-4c6a-8bdf-5ca95bb8666c', u'deploy_ramdisk':           |
|                        | u'8119f9d9-1bc6-4845-9e8a-6c24a720426d'}                              |
| driver_internal_info   | {}                                                                    |
| extra                  | {}                                                                    |
| inspect_interface      | inspector                                                             |
| inspection_finished_at | None                                                                  |
| inspection_started_at  | None                                                                  |
| instance_info          | {}                                                                    |
| instance_uuid          | None                                                                  |
| last_error             | Failed to validate power driver interface for node da7d97e1-f1cf-     |
|                        | 46dd-a951-834ac165783f. Error: %(prop)s is not set either in the      |
|                        | configuration orin the node's driver_info                             |
| maintenance            | False                                                                 |
| maintenance_reason     | None                                                                  |
| management_interface   | staging-ovirt                                                         |
| name                   | osp13-controller1                                                     |
| network_interface      | flat                                                                  |
| power_interface        | staging-ovirt                                                         |
| power_state            | None                                                                  |
| properties             | {u'memory_mb': u'4096', u'cpu_arch': u'x86_64', u'local_gb': u'40',   |
|                        | u'cpus': u'2', u'capabilities': u'profile:control,boot_option:local'} |
| provision_state        | enroll                                                                |
| provision_updated_at   | 2018-03-12T18:01:53+00:00                                             |
| raid_config            | {}                                                                    |
| raid_interface         | no-raid                                                               |
| reservation            | None                                                                  |
| resource_class         | baremetal                                                             |
| storage_interface      | noop                                                                  |
| target_power_state     | None                                                                  |
| target_provision_state | None                                                                  |
| target_raid_config     | {}                                                                    |
| traits                 |                                                                       |
| updated_at             | 2018-03-12T18:31:40+00:00                                             |
| uuid                   | da7d97e1-f1cf-46dd-a951-834ac165783f                                  |
| vendor_interface       | no-vendor                                                             |
+------------------------+-----------------------------------------------------------------------+

Comment 3 mlammon 2018-05-01 15:56:18 UTC
Latest installed on RHV env using osp 13 puddle: 2018-04-26.3

Env:
(undercloud) [stack@undercloud ~]$ rpm -qa | grep openstack-ironic-staging-drivers
openstack-ironic-staging-drivers-0.9.0-4.el7ost.noarch

Introspection of 3 controller , 1 compute worked using credentials from instackenv.json

This issue has been verified

Comment 5 errata-xmlrpc 2018-06-27 13:36:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.