Bug 1554628 - Bridge and slaves status are wrong when one of the slaves has the host connection
Summary: Bridge and slaves status are wrong when one of the slaves has the host connec...
Keywords:
Status: CLOSED DUPLICATE of bug 1548265
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: sushil kulkarni
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: ovirt-node-ng-43-el76-platform
TreeView+ depends on / blocked
 
Reported: 2018-03-13 03:40 UTC by Huijuan Zhao
Modified: 2018-03-20 01:26 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-20 01:26:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of bridge configuration (82.45 KB, image/png)
2018-03-13 03:40 UTC, Huijuan Zhao
no flags Details
All logs from host when both two slaves have dhcp ip (10.81 MB, application/x-gzip)
2018-03-13 03:44 UTC, Huijuan Zhao
no flags Details

Description Huijuan Zhao 2018-03-13 03:40:10 UTC
Created attachment 1407416 [details]
Screenshot of bridge configuration

Description of problem:
Create bridge over two slaves in cockpit, if one of the slaves has the host connection, the status of bond and slaves are wrong.
1. If both two slaves are "ON" and have dhcp IP, the bridge over the two slaves can not get dhcp IP, and the two slaves are still "ON" with dhcp IP.
2. If only primary slave is "ON" and has dhcp IP, the bridge can get dhcp IP, but the primary slave is still "ON" with dhcp IP.

Expected results: Only bridge can get dhcp IP,  the slaves have NO dhcp IP automatically.


Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.1-20180307.0
imgbased-0.9.54-0.1.el7ev.noarch
cockpit-ws-160-3.el7.x86_64
cockpit-ovirt-dashboard-0.10.10-0.el7ev.noarch
NetworkManager-1.10.2-13.el7.x86_64
glib-networking-2.50.0-1.el7.x86_64
libvirt-daemon-driver-network-3.9.0-13.el7.x86_64


How reproducible:
100%
Keywords: cockpit -> networking


Steps to Reproduce:

Scenario 1:
1. Install redhat-virtualization-host-4.1-20180307.0
2. Enable("ON") NIC1(eno1, can get dhcp ip: 10.73.130.225), connect host via cockpit:
   https://10.73.130.225:9090/network
3. Enter to networking page, enable("ON") NIC2(eno2, can get dhcp ip: 10.73.128.240),
4. Create bridge0 over the above two slave NICs(eno1, eno2)

Actual results:
1. After step 4, bridge0 can NOT get dhcp IP, but the two slaves are still connected with previous dhcp IP

Expected results:
1. After step 4, bridge0 can get dhcp IP, the two slaves should have NO dhcp IP automatically.

Scenario 2:
1. Install redhat-virtualization-host-4.1-20180307.0
2. Enable("ON") NIC1(eno1, can get dhcp ip: 10.73.130.225), connect host via cockpit:
   https://10.73.130.225:9090/network
3. Enter to networking page, check NIC2(eno2) is "OFF" with no dhcp IP
4. Create bridge0 over the above two slave NICs(eno1, eno2)

Actual results:
1. After step 4, bridge0 can get dhcp IP, but the slave(eno1) is still connected with previous dhcp IP

Expected results:
1. After step 4, the slave(eno1) should have NO dhcp IP. But change to bridge0 to be connected.


Additional info:
When both two slaves have DHCP ip, bridge can not get dhcp ip:
# ip a s
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 08:94:ef:21:c0:4d brd ff:ff:ff:ff:ff:ff
    inet 10.73.130.225/23 brd 10.73.131.255 scope global noprefixroute dynamic eno1
       valid_lft 39755sec preferred_lft 39755sec
    inet6 2620:52:0:4982:bead:949c:54c4:74cf/64 scope global noprefixroute dynamic 
       valid_lft 2592000sec preferred_lft 604800sec
    inet6 fe80::1b41:c3be:d613:c00d/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: eno2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 08:94:ef:21:c0:4e brd ff:ff:ff:ff:ff:ff
    inet 10.73.128.240/24 brd 10.73.128.255 scope global noprefixroute dynamic eno2
       valid_lft 1377sec preferred_lft 1377sec
    inet6 2620:52:0:4980:efc7:66f7:c01f:763b/64 scope global noprefixroute dynamic 
       valid_lft 2591813sec preferred_lft 604613sec
    inet6 fe80::28f1:cd7c:6284:6614/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
26: bridge0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 02:10:1f:74:81:44 brd ff:ff:ff:ff:ff:ff

Comment 2 Huijuan Zhao 2018-03-13 03:44:02 UTC
Created attachment 1407417 [details]
All logs from host when both two slaves have dhcp ip

Comment 3 Beniamino Galvani 2018-03-19 16:45:01 UTC
This is the same issue as bug 1548265 (except that there the master is a bond instead of a bridge, but the master type is not really relevant). Any objections in closing this as a duplicate?

Comment 4 Huijuan Zhao 2018-03-20 01:26:57 UTC
(In reply to Beniamino Galvani from comment #3)
> This is the same issue as bug 1548265 (except that there the master is a
> bond instead of a bridge, but the master type is not really relevant). Any
> objections in closing this as a duplicate?

ok, agree.

*** This bug has been marked as a duplicate of bug 1548265 ***


Note You need to log in before you can comment on or make changes to this bug.