Bug 1554701 - can't paste the flags emoji
Summary: can't paste the flags emoji
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-13 08:13 UTC by lnie
Modified: 2021-10-04 16:24 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-04 06:17:27 UTC
Type: Bug


Attachments (Terms of Use)
screencast (370.28 KB, application/octet-stream)
2018-03-13 08:13 UTC, lnie
no flags Details
journal (897.68 KB, text/plain)
2018-03-13 08:41 UTC, lnie
no flags Details
emoji-picker-flags-gnome-terminal.png (292.19 KB, image/png)
2018-03-14 07:19 UTC, Mike FABIAN
no flags Details
screenshot (83.03 KB, image/png)
2018-03-14 09:40 UTC, lnie
no flags Details
journal (84.51 KB, text/plain)
2018-03-14 09:41 UTC, lnie
no flags Details

Description lnie 2018-03-13 08:13:53 UTC
Created attachment 1407452 [details]
screencast

Description of problem:
As shown in the attached screencast.

Version-Release number of selected component (if applicable):
emoji-picker-1.5.35-1.fc28

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2018-03-13 08:41:17 UTC
Created attachment 1407474 [details]
journal

Comment 2 Mike FABIAN 2018-03-14 07:19:55 UTC
Created attachment 1407858 [details]
emoji-picker-flags-gnome-terminal.png

That is a gnome-terminal problem. It works in gedit and in other gnome programs like in the "enter command" dialog as shown in this screenshot.

gnome-terminal cannot display most emoji sequences correctly (i.e. emoji
which consist of more than one character). For example, gnome-terminal
cannot display any of the following emoji sequences correctly:

πŸ‡¨πŸ‡¦
πŸ‘©β€πŸŒΎ
πŸ‘©β€β€οΈβ€πŸ‘¨
πŸ™‹πŸΎβ€β™€οΈ
πŸ‘§πŸΎ

In emoji-picker, if you right click on an emoji, some information about that emoji is displayed. There you can see whether the emoji is a single character or a sequence. For example for the Canadian flag you will find:

πŸ‡¨πŸ‡¦ U+1F1E8 U+1F1E6

Comment 3 Mike FABIAN 2018-03-14 07:20:31 UTC
Move bug to gnome-terminal.

Comment 4 lnie 2018-03-14 09:40:33 UTC
Created attachment 1407882 [details]
screenshot

Comment 5 lnie 2018-03-14 09:41:04 UTC
Created attachment 1407883 [details]
journal

Comment 6 lnie 2018-03-14 09:42:30 UTC
Attached screenshot is what I got when I try to paste some flags and others to libreoffice writer

Comment 7 Mike FABIAN 2018-03-14 11:09:09 UTC
(In reply to lnie from comment #6)
> Attached screenshot is what I got when I try to paste some flags and others
> to libreoffice writer

Yes, libreoffice does not support these either. That is a problem
in libreoffice, not in the inputmethod used to input these sequences.

Comment 8 sachin 2019-04-03 08:17:00 UTC
Above reported issue is reproducible in Fedora 30  with Fedora-Everything-netinst-x86_64-30-20190401.n.0.iso 

able to input flags in gedit, but not on terminal and libreoffice.

Comment 9 Mike FABIAN 2020-04-07 06:13:34 UTC
Pasting πŸ‡¨πŸ‡¦ U+1F1E8 U+1F1E6 into libreoffice works now.
But it still doesn’t work to past it into gnome-terminal.

Comment 10 Mike FABIAN 2020-04-07 06:16:46 UTC
Pasting πŸ‘©β€πŸŒΎ U+1F9D1 U+200D U+1F33E into libreoffice still fails (and it also fails pasting it into gnome-terminal).

Comment 11 Mike FABIAN 2021-01-25 06:26:54 UTC
Unchanged in Fedora 33.

Comment 12 Matthias Clasen 2021-01-25 14:58:20 UTC
I believe this is https://gitlab.gnome.org/GNOME/pango/-/issues/293

Comment 13 Peng Wu 2021-01-26 06:44:02 UTC
For gnome-terminal, vte may not support Unicode Emoji sequence.

URL: https://gitlab.gnome.org/GNOME/vte/-/blob/master/src/vteunistr.h#L30

Comment 14 Jens Petersen 2021-10-04 06:17:27 UTC
Please file a upstream against vte, but this is not easy to fix due to its rendering limitations.

Comment 15 Christian Persch 2021-10-04 16:24:45 UTC
While the issue here is mis-stated (the issue is combining the two RI characters of width 1 into one cell of width 2, and has nothing to do with the rendering itself), there already is an upstream bug at https://gitlab.gnome.org/GNOME/vte/-/issues/2317 . (Please don't an extraneous comment there; the issue is already known and understood upstream.)


Note You need to log in before you can comment on or make changes to this bug.