Bug 1554813 - Enter key from num pad doesn't work in IBus Emojier
Summary: Enter key from num pad doesn't work in IBus Emojier
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus   
(Show other bugs)
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-13 12:31 UTC by bhavin192
Modified: 2018-03-30 12:56 UTC (History)
4 users (show)

Fixed In Version: ibus-1.5.18-3.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-30 12:56:08 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for ui/gtk3/emojier.vala (2.62 KB, patch)
2018-03-14 06:53 UTC, fujiwara
no flags Details | Diff

Description bhavin192 2018-03-13 12:31:47 UTC
Description of problem:
The enter key and arrows (4, 8, 6, 2) from num pad don't work on IBus Emojier (Emoji Choice) 

Version-Release number of selected component (if applicable):
ibus-1.5.18-1.fc28.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Turn off Num Lock
2. Open gedit
3. Open Ctrl + Shift + e  
4. Search an emoji and try to press Enter or try to use 2, 4, 6, 8 (*from num pad*)

Actual results:
Nothing happens as if key was not pressed at all

Expected results:
It should print that emoji or should be able to traverse through the result list. 

Additional info:
I have tested with different keyboards from different vendors

Comment 1 fujiwara 2018-03-14 05:54:34 UTC
I cannot reproduce this.
Did you enable NumLock ?

Comment 2 bhavin192 2018-03-14 06:08:58 UTC
As I have mentioned in the steps to reproduce,
when the Num Lock is disabled I was not able to use the keys 2, 4, 6, 8 to traverse through emojis. Ideally one should be able to use these numbers as arrow keys.
If Num Lock is disabled, I'm able to type the numbers.

In both the cases (Num Lock on and off) the Enter key (from num pad) does't work.

Comment 3 fujiwara 2018-03-14 06:26:53 UTC
Sorry, I mistook your description about Enter key.

Comment 4 fujiwara 2018-03-14 06:53 UTC
Created attachment 1407856 [details]
Patch for ui/gtk3/emojier.vala

The proposed patch.

Comment 5 Fedora Update System 2018-03-15 09:08:37 UTC
ibus-1.5.18-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1a75f008aa

Comment 6 Fedora Update System 2018-03-15 13:32:22 UTC
ibus-1.5.18-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1a75f008aa

Comment 7 Fedora Update System 2018-03-30 12:56:08 UTC
ibus-1.5.18-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.