Bug 155490 - Segmentation faults in Perl_gv_fetchpv(), Perl_find_script(), Perl_sv_gets()
Segmentation faults in Perl_gv_fetchpv(), Perl_find_script(), Perl_sv_gets()
Status: CLOSED DUPLICATE of bug 154759
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
: 155487 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-20 16:10 EDT by Hans Ecke
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-22 15:20:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of segfault in Perl_sv_gets (1.96 KB, text/plain)
2005-04-20 16:15 EDT, Hans Ecke
no flags Details
segfault in Perl_find_script() (1.90 KB, text/plain)
2005-04-20 16:17 EDT, Hans Ecke
no flags Details
segfault in Perl_gv_fetchpv() - this one also has local variables (4.01 KB, text/plain)
2005-04-20 16:18 EDT, Hans Ecke
no flags Details

  None (edit)
Description Hans Ecke 2005-04-20 16:10:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; en_US) KHTML/3.4.0 (like Gecko)

Description of problem:
Recently I have seen segmentation faults crop up in unattended (cron) perl   
scripts. Unfortunately I can not reproduce them interactively.  
   
I set them to create core files and downloaded perl-debuginfo. Attached you  
will find some backtraces that might help. 
 
I'm sorry I can not be more specific, please advise. 

Version-Release number of selected component (if applicable):
perl-5.8.5-9

How reproducible:
Sometimes

Steps to Reproduce:
1.Have perl scripts in cron (/etc/cron.hourly/ etc) 
2.Use BSD::Resource to make them create core files if interrupted 
3.Wait for messages in the mail 
   

Actual Results:  Perl scripts die from segmentation fault and create core files 

Expected Results:  They should not die. Perl should never ever see a segfault. 

Additional info:

See attached gdb backtraces.
Comment 1 Hans Ecke 2005-04-20 16:12:20 EDT
*** Bug 155487 has been marked as a duplicate of this bug. ***
Comment 2 Hans Ecke 2005-04-20 16:15:36 EDT
Created attachment 113434 [details]
backtrace of segfault in Perl_sv_gets

Please note that even though this is a segfault in a custom script, they also
happen in one liners like 'perl -p -e"s/\s+$//"'
Comment 3 Hans Ecke 2005-04-20 16:17:12 EDT
Created attachment 113435 [details]
segfault in Perl_find_script()
Comment 4 Hans Ecke 2005-04-20 16:18:42 EDT
Created attachment 113436 [details]
segfault in Perl_gv_fetchpv() - this one also has local variables
Comment 5 Hans Ecke 2005-04-20 19:20:31 EDT
One of the machines hit by this also displays bug #154759 - there might be a 
connection. I'm running the 2.6.11-1.14_FC3 kernel on them 
Comment 6 Ville Skyttä 2005-04-21 12:52:42 EDT
In addition to kernel, glibc has also been updated lately.  No clue if it could
affect this or not.
Comment 7 Hans Ecke 2005-04-22 15:20:19 EDT
Since I turned exec-shield randomization off I do not see these crashes  
anymore. I believe this is a kernel issue with fedora's newest 2.6.11-1.14  
kernel. As I say in my last comment in bug #154759, I think kernel/exec-shield   
people should look at this.  
  
Ville, glibc was changed on a fedora2 machine in November 2004, on the fedora3  
on 2005.04.07. The new kernel came on 2005.04.13. That is close, but the 
problems started after the new kernel was installed. 
 
Resolving as duplicate.  

*** This bug has been marked as a duplicate of 154759 ***

Note You need to log in before you can comment on or make changes to this bug.