Bug 1554939 - Hostsubnet not creating subnets as intended when specifying osm_host_subnet_length during installation
Summary: Hostsubnet not creating subnets as intended when specifying osm_host_subnet_l...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 3.10.0
Assignee: jtanenba
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-13 15:37 UTC by Manikandan Somasundaram
Modified: 2018-07-30 19:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:10:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:11:12 UTC
Github openshift openshift-docs pull 8523 None None None 2018-04-12 18:09:56 UTC

Comment 1 jtanenba 2018-03-19 18:52:19 UTC
This is working as intended, to avoid confusion if a subnet extends to the next higher octet we rotate the bits so all subnets with 0's in the shared octet are allocated first. If you had more nodes the system would fill in the gaps.

Comment 2 jtanenba 2018-04-17 16:05:22 UTC
PR link 

https://github.com/openshift/openshift-docs/pull/8523

Comment 4 Hongan Li 2018-05-21 06:25:20 UTC
Doc looks good, bug verified

Comment 6 errata-xmlrpc 2018-07-30 19:10:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.