Bug 1555111 - FFU: ceph-ansible playbooks are failing when callback_whitelist=profile_tasks is set in /etc/ansible/ansible.cfg
Summary: FFU: ceph-ansible playbooks are failing when callback_whitelist=profile_tasks...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-14 00:29 UTC by Marius Cornea
Modified: 2018-06-27 13:37 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-common-8.6.1-0.20180417180425.19d9b91.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:36:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1755539 None None None 2018-03-14 00:29:08 UTC
OpenStack gerrit 552636 None master: MERGED tripleo-common: Force ANSIBLE_CALLBACK_WHITELIST to empty list for collect_nodes_uuid (Ic133f99988fcc4f6e20ef327b6f2e753... 2018-04-19 14:28:35 UTC
OpenStack gerrit 559965 None stable/queens: MERGED tripleo-common: Force ANSIBLE_CALLBACK_WHITELIST to empty list for collect_nodes_uuid (Ic133f99988fcc4f6e20ef327b6f2e753... 2018-04-19 14:28:30 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:37:23 UTC

Description Marius Cornea 2018-03-14 00:29:08 UTC
Description of problem:
FFU: ceph-ansible playbooks are failing when callback_whitelist=profile_tasks is set in /etc/ansible/ansible.cfg

collect_nodes_uuid parses json output from ansible-playbook command, but it might be polluted with spurious lines if additional output callbacks are enabled

Version-Release number of selected component (if applicable):
openstack-tripleo-common-8.4.1-0.20180224032817.d51ed49.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10 with ceph osd nodes
2. Upgrade undercloud to OSP13
3. Add callback_whitelist=profile_tasks  to /etc/ansible/ansible.cfg
4. Upgrade overcloud

Actual results:
ceph-ansible playbook fails.

Expected results:
ceph-ansible succeeds

Additional info:

Comment 9 Yogev Rabl 2018-06-21 14:46:57 UTC
verified on openstack-tripleo-common-8.6.1-20.el7ost.noarch

Comment 11 errata-xmlrpc 2018-06-27 13:36:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.