Bug 1555220 - registry url for registry-console image is not modified when openshift_examples_modify_imagestreams=true
Summary: registry url for registry-console image is not modified when openshift_exampl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.9.z
Assignee: Michael Gugino
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-14 08:21 UTC by Johnny Liu
Modified: 2018-05-17 06:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-17 06:42:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:43:12 UTC

Description Johnny Liu 2018-03-14 08:21:50 UTC
Description of problem:
This issue does not happen with openshift-ansible-3.9.2-1. So it is a regression bug.
The bug is introduced by dc5ff9724234b3d83470879c7ebb794ed7f3cdea;

But seem like it is already fixed by c69216d17595d37f4010160db15bf88b4d92fb52 in master branch.

Open this bug for tracking if PR would be landed into rpm package.

Version-Release number of the following components:
openshift-ansible-3.9.7-1.git.0.60d5c90.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Set oreg_url to a non-default registry (not registry.access.redhat.com), and openshift_examples_modify_imagestreams=true.
2. Trigger installation.
3.

Actual results:
The following steps are skipped, which will lead registry-console pod is still pulling image from default official product registry.
<--snip-->
TASK [openshift_hosted_templates : Modify registry paths if registry_url is not registry.access.redhat.com] ***
Wednesday 14 March 2018  04:03:45 +0000 (0:00:00.146)       0:06:51.872 ******* 
skipping: [ec2-184-72-94-244.compute-1.amazonaws.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}
<--snip-->

Expected results:
registry-console image should being pulled from non-default registry according to oreg_url setting.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Michael Gugino 2018-03-14 17:12:01 UTC
I am unable to replicate this with commit dc5ff9724234b3d83470879c7ebb794ed7f3cdea

Please post inventory and re-verify that you are using that commit.  I don't see a reason for this to fail as the logic is driven from inventory variables and some basic manipulation in role openshift_example/defaults/main.yml.

Comment 4 Michael Gugino 2018-03-15 13:11:00 UTC
PR Created: https://github.com/openshift/openshift-ansible/pull/7537

Comment 8 Johnny Liu 2018-04-20 00:58:46 UTC
According to comment 6, move this to VERIFIED.

Comment 11 errata-xmlrpc 2018-05-17 06:42:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.