Bug 1555323 - WTF is wireshark-qt pulled as dependency
Summary: WTF is wireshark-qt pulled as dependency
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wireshark
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Ruprich 🐧
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-14 13:37 UTC by Harald Reindl
Modified: 2018-04-17 00:12 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-03-27 19:59:06 UTC


Attachments (Terms of Use)

Description Harald Reindl 2018-03-14 13:37:31 UTC
it's one thing that the gtk-UI no longer exists but this is no justification to pull wireshark-qt 1:2.4.5-2.fc27 on machines where users are happy with "tshark"

Comment 1 Harald Reindl 2018-03-14 13:49:16 UTC
on a headless server that means pulling the following deps:

 glibmm24                                                 x86_64                              2.54.1-1.fc27                                     fedora                                       586 k
 gstreamer1-plugins-bad-free                              x86_64                              1.12.4-1.fc27                                     updates                                      1.9 M
 jack-audio-connection-kit                                x86_64                              1.9.12-1.fc27                                     updates                                      509 k
 libconfig                                                x86_64                              1.5-7.fc27                                        fedora                                        65 k
 libdvdnav                                                x86_64                              5.0.3-7.fc27                                      fedora                                        59 k
 libdvdread                                               x86_64                              5.0.3-7.fc27                                      fedora                                        73 k
 libffado                                                 x86_64                              2.4.0-1.fc27                                      updates                                      802 k
 libiec61883                                              x86_64                              1.2.0-17.fc27                                     fedora                                        41 k
 libmpcdec                                                x86_64                              1.2.6-19.fc27                                     fedora                                        35 k
 libsigc++20                                              x86_64                              2.10.0-4.fc27                                     fedora                                        42 k
 libsrtp                                                  x86_64                              1.5.4-6.fc27                                      fedora                                       293 k
 libxml++                                                 x86_64                              2.40.1-5.fc27                                     fedora                                        90 k
 mesa-libwayland-egl                                      x86_64                              17.3.6-1.fc27                                     updates                                       30 k 
 openal-soft                                              x86_64                              1.18.2-5.fc27                                     updates                                      392 k 
 portaudio                                                x86_64                              19-26.fc27                                        fedora                                        95 k 
 qt5-qtmultimedia                                         x86_64                              5.9.4-1.fc27                                      updates                                      815 k 
 soundtouch                                               x86_64                              1.9.2-6.fc27                                      fedora                                        71 k 
 wireshark-qt                                             x86_64                              1:2.4.5-2.fc27                                    updates-testing                              3.5 M 
 xdg-utils                                                noarch                              1.1.2-4.fc27                                      updates                                       83 k

Comment 2 Harald Reindl 2018-03-14 13:52:50 UTC
no way to remove the UI stuff

[root@testserver:~]$ rpm -e wireshark-qt-2.4.5-2.fc27.x86_64
error: Failed dependencies:
        wireshark-qt = 1:2.4.5-2.fc27 is needed by (installed) wireshark-1:2.4.5-2.fc27.x86_64

[root@testserver:~]$ rpm -e wireshark
error: Failed dependencies:
        wireshark = 1:2.4.5-2.fc27 is needed by (installed) wireshark-cli-1:2.4.5-2.fc27.x86_64

Comment 3 Michal Ruprich 🐧 2018-03-14 15:30:48 UTC
No this is completely fine. As it says in the description in the wireshark metapackage, it contains wireshark-qt and wireshark-cli. But until now only wireshark-cli was installed. If you want to use just tshark, you should always install wireshak-cli by itself. It is explicitply said in the update notes - "Added wireshark-qt to wireshark metapackage".

Comment 4 Harald Reindl 2018-03-14 16:21:23 UTC
> you should always install wireshak-cli by itself

how do you imagine that when the f**ing wireshark-cli requires the "wireshark metapackage" - would you mind to read what people report?

[root@testserver:~]$ rpm -e wireshark
error: Failed dependencies:
        wireshark = 1:2.4.5-2.fc27 is needed by (installed) wireshark-cli-1:2.4.5-2.fc27.x86_64

Comment 5 Harald Reindl 2018-03-14 17:17:51 UTC
Requires: %{name} = %{epoch}:%{version}-%{release} translatete means "Requires: wireshark = 2.4.5-2"

%package cli
Summary: Network traffic analyzer
Group: Applications/Internet
Requires: %{name} = %{epoch}:%{version}-%{release}
Requires(pre): shadow-utils
Requires(post): systemd-udev

Comment 6 Harald Reindl 2018-03-14 17:49:44 UTC
filed also a bug against rpm because such a braindead dependency chain "metapackage requires sub-package and sub-package requires metapackage itself" should not be allowed to start with https://bugzilla.redhat.com/show_bug.cgi?id=1555445

Comment 7 Michal Ruprich 🐧 2018-03-15 06:29:22 UTC
Ok, I need you to calm down. The problem with the metapackage has already been reported here:
https://bugzilla.redhat.com/show_bug.cgi?id=1554818

And as I said in that bug I missed this mistake due to big changes in the spec file. The dependency on the metapackage has been there for a long time and it only became a problem now when I added the wireshark-qt to the metapackage. I will fix this with new release.

Bugzilla tool is exactly for this - reporting problems. Please don't use it to express your anger in the way you do. It is really unnecessary.

Comment 8 Harald Reindl 2018-03-15 10:19:24 UTC
cause and effect

well, next time read what was reported because https://bugzilla.redhat.com/show_bug.cgi?id=1555323#c2 clearly showd the issue 1.5 hours before your "No this is completely fine" 

when you don't want to read just try out what you preach at your own because if you would have done "If you want to use just tshark, you should always install wireshak-cli by itself" before "Save changes" you would have seen it's not possible

Comment 9 Michal Ruprich 🐧 2018-03-15 10:26:48 UTC
Again, please no need to get angry here. This is why every update into branched Fedora goes through testing phase and gathers karma. I simply missed this issue and you reported it. It will be fixed in a few moments.

Comment 10 Fedora Update System 2018-03-15 10:43:50 UTC
wireshark-2.4.5-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-bfdad62cd6

Comment 11 Fedora Update System 2018-03-15 10:46:59 UTC
wireshark-2.4.5-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cdf3f8e8b0

Comment 12 Fedora Update System 2018-03-15 13:32:59 UTC
wireshark-2.4.5-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-bfdad62cd6

Comment 13 Fedora Update System 2018-03-15 16:27:19 UTC
wireshark-2.4.5-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cdf3f8e8b0

Comment 14 Fedora Update System 2018-03-27 19:59:06 UTC
wireshark-2.4.5-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2018-04-17 00:12:00 UTC
wireshark-2.4.5-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.