Bug 155534 - Kbabel allows to type in english also even though iiimf is on !!!
Kbabel allows to type in english also even though iiimf is on !!!
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kdesdk (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-21 03:35 EDT by Ankit Patel
Modified: 2015-07-13 13:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 05:02:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ankit Patel 2005-04-21 03:35:22 EDT
Description of problem:
We can type in English in kbabel even if iiinf is on !!!

Version-Release number of selected component (if applicable):


How reproducible:
When you start kbabel and by pressing 'ctrl+space' make on the iiimf. If you
type normally then it will type characters in your native language but by typing
with combinations of 'alt' you will get english characters.

Steps to Reproduce:
1.Start Kbabel
2.press ctrl + space
3.start typing
4.press 'alt' key, and start typing.
  
Actual results:
Without pressing 'alt' key, it will type in login language. (This is correct)
With pressing 'alt' key, it will start typing in english even though the iiimf
is on. (This is not correct)

Expected results:
Without pressing 'alt' key, it should type in login laguage.
With pressing 'alt' key, it should not type any character or open a respective
menu item according to the short-cut, that's what gedit does.

Additional info:
Comment 1 Leon Ho 2005-05-16 22:08:13 EDT
Ankit, does it happen if it is in application like kedit or kate?
Comment 2 Ankit Patel 2005-05-17 00:04:24 EDT
It happens with all KDE specific applications. I have tried it on kate and kbabel.
Comment 4 Jens Petersen 2008-03-04 23:20:09 EST
I take it, this is ok with RHEL5?
Comment 5 Ankit Patel 2008-03-05 00:14:30 EST
We have scim in RHEL5. I haven't tried installing iiimf on RHEL5 and test it.
Can we actually install it on RHEL5?

Note You need to log in before you can comment on or make changes to this bug.