Bug 1555384 - Broken Exec= line in com.redhat.SubscriptionManager.service
Summary: Broken Exec= line in com.redhat.SubscriptionManager.service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: subscription-manager
Version: 27
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Jiri Hnidek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1576962 1581762 (view as bug list)
Depends On:
Blocks: 1600390
TreeView+ depends on / blocked
 
Reported: 2018-03-14 15:10 UTC by Martin Pitt
Modified: 2018-11-15 02:13 UTC (History)
8 users (show)

Fixed In Version: subscription-manager-1.21.5-1.fc28 subscription-manager-1.24.2-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1600390 (view as bug list)
Environment:
Last Closed: 2018-06-16 20:16:12 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1825 0 None None None 2018-06-04 10:44:59 UTC
Red Hat Bugzilla 1576962 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Bugzilla 1591770 1 None None None 2021-01-20 06:05:38 UTC

Internal Links: 1576962 1591770

Description Martin Pitt 2018-03-14 15:10:05 UTC
Description of problem: subscription-manager D-Bus interface is broken, as its service file has an invalid Exec line:

$ grep Exec /usr/share/dbus-1/system-services/com.redhat.SubscriptionManager.service
Exec=b'/usr/libexec'/rhsmd

This looks like it was generated by a Python program which missed to convert between bytes and string.

Version-Release number of selected component (if applicable):

subscription-manager-1.21.2-3.fc27.x86_64

How reproducible: Always


Steps to Reproduce:
1. busctl call  com.redhat.SubscriptionManager /EntitlementStatus com.redhat.SubscriptionManager.EntitlementStatus check_status

Actual results:
Fails with: Cannot launch daemon, file not found or permissions invalid

Expected results:
Call succeeds and returns an int.

Comment 1 Andreas Nilsson 2018-05-23 15:26:10 UTC
*** Bug 1581762 has been marked as a duplicate of this bug. ***

Comment 2 Chris Snyder 2018-06-01 18:53:26 UTC
*** Bug 1576962 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2018-06-07 22:29:33 UTC
subscription-manager-1.21.5-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c0e02d9e12

Comment 4 Fedora Update System 2018-06-07 22:29:45 UTC
subscription-manager-1.21.5-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b93c0d8968

Comment 5 Fedora Update System 2018-06-08 13:00:37 UTC
subscription-manager-1.21.5-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b93c0d8968

Comment 6 Fedora Update System 2018-06-08 19:48:53 UTC
subscription-manager-1.21.5-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c0e02d9e12

Comment 7 Fedora Update System 2018-06-16 20:16:12 UTC
subscription-manager-1.21.5-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2018-11-05 22:57:05 UTC
subscription-manager-1.24.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-91ba32a0ff

Comment 9 Fedora Update System 2018-11-06 22:46:08 UTC
subscription-manager-1.24.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-91ba32a0ff

Comment 10 Fedora Update System 2018-11-15 02:13:15 UTC
subscription-manager-1.24.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.