Bug 1555390 - [APB] --broker flag fails if the broker route's suffix is not specified
Summary: [APB] --broker flag fails if the broker route's suffix is not specified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.7.z
Assignee: Dylan Murray
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-14 15:20 UTC by Dylan Murray
Modified: 2018-06-27 07:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The --broker flag misbehaved with improper suffixes/prefixes. Consequence: Commands like `apb list --broker <route_with_no_suffix>` did not behave as expected. Fix: Backported some newer fixes to 3.7 so that the tooling automatically will append/prepend proper suffix/prefix. Result: `apb list` should just work, --broker flag not even needed.
Clone Of:
Environment:
Last Closed: 2018-06-27 07:59:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2009 None None None 2018-06-27 07:59:38 UTC

Description Dylan Murray 2018-03-14 15:20:55 UTC
Description of problem:
In versions 1.0.4 and prior of the APB tooling specifying the correct broker route with the --broker flag would still fail if the user did not specify the proper suffix to the route such as:
<broker_route>/ansible-service-broker/v2/catalog

Version-Release number of selected component (if applicable):
3.7.0

How reproducible:
100%

Steps to Reproduce:
1. apb list --broker <broker_route_with_no_suffix>


Actual results:
Error: Attempt to list APBs in the broker returned status: 404
Unable to list APBs in Ansible Service Broker.

Expected results:
Return the list of APBs because the tooling appends the suffix for me.

Comment 3 Zhang Cheng 2018-04-08 05:48:32 UTC
Changing status to ON_QA since errata image ready for test.

Comment 4 Jian Zhang 2018-04-09 02:01:20 UTC
It works well as we expected, LGTM, verified.

[root@host-172-16-120-59 ~]# rpm -qa | grep apb
apb-1.0.5-1.el7.noarch

Comment 6 errata-xmlrpc 2018-06-27 07:59:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2009


Note You need to log in before you can comment on or make changes to this bug.