Bug 155551 - NetworkManager never returns with error on wrong password/key
NetworkManager never returns with error on wrong password/key
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-04-21 08:13 EDT by Christian Schaller
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 22:09:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of network login dialog (which is grey no matter what) (35.25 KB, image/png)
2005-05-13 12:32 EDT, Christian Schaller
no flags Details

  None (edit)
Description Christian Schaller 2005-04-21 08:13:05 EDT
At work I have a host of wireless networks within range. The only one I am
interested in is our own. If I enter wrong password/key in network manager it
never returns saying it was unable to connect, instead it just tries some of the
other networks. Since one of those networks is open it always connects to that
instead, which I find rather frustrating. Only way to be allowed to retype the
network password/key is to delete it with gconf, which I don't think is a very
userfriendly option. If I manually tell NetworkManager to connect to a specific
network it should give me error dialogs until I am actually connected to that
network.
Comment 1 Dan Williams 2005-05-05 15:10:48 EDT
Can you post the output of /var/log/messages after starting NetworkManager and
after you've tried once to connect to your access point using "Other wireless
networks..."?

Thanks!
Comment 2 Christian Schaller 2005-05-13 12:31:23 EDT
Never connected using 'Other Wireless Networks' before, just tried the dialog
that pops up when you choose your network of choice from the list. With Other
Wireless networks I was able to log in today. Thanks. On the other hand with the
dialog that pops up when you just choose the network from the list seems even
more broken now, with current devel packages the 'Login to network' button is
greyed out no matter what. (attaching screenshot)
Comment 3 Christian Schaller 2005-05-13 12:32:26 EDT
Created attachment 114342 [details]
Screenshot of network login dialog (which is grey no matter what)
Comment 4 Dan Williams 2005-05-13 12:36:21 EDT
128-bit Hex WEP keys have 26 characters, but I counted 28 in your screenshot. 
Are you sure that's the right key?
Comment 5 Christian Schaller 2005-05-13 12:53:02 EDT
it is a bogus key, I altered it heavily (by random key pressing and deleting)
before taking the shot as I felt it would be kinda stupid to post a shot with
our actual key in it :)

Switching to any of the two other options (passphrase or ascii) it is also still
grey.
Comment 6 Dan Williams 2005-05-16 15:48:09 EDT
Ok, the greyed-out OK button should be fixed in CVS HEAD and will also be in an
FC4 update right after FC4 comes out.
Comment 7 Bill Nottingham 2006-09-21 22:09:39 EDT
Closing bugs in MODIFIED state from prior Fedora releases. If this bug persists
in a current Fedora release (such as Fedora Core 5 or later), please reopen and
set the version appropriately.

Note You need to log in before you can comment on or make changes to this bug.