Bug 1555745 - gnome-software fails to install libreoffice langpack
Summary: gnome-software fails to install libreoffice langpack
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-14 19:36 UTC by Till Maas
Modified: 2018-03-15 13:39 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-03-15 13:39:54 UTC


Attachments (Terms of Use)

Description Till Maas 2018-03-14 19:36:02 UTC
Description of problem:
As part of the i18n test day I started libreoffice in a de_DE locale freshly installed F28 nightly workstation image. gnome told me that additional software is needed - the de langpack. However it failed to actually install it. It worked find with dnf install langpacks-de, though.

Version-Release number of selected component (if applicable):
3.27.92-1.fc28

How reproducible:
always

Steps to Reproduce:
1. run libreoffice in de_DE locale without de langpack


Actual results:
fails to install langpack

Expected results:
should install langpack or at least tell me why it failed.

Additional info:

Comment 1 Kalev Lember 2018-03-14 21:05:20 UTC
How did it fail? Was there an error message?

Comment 2 Kalev Lember 2018-03-14 21:09:10 UTC
I suspect what you have here is the missing openh264 repo metadata issue, https://bugzilla.redhat.com/show_bug.cgi?id=1554981#c10

Comment 3 Till Maas 2018-03-14 21:52:57 UTC
It says that it was not found and shows a link to a website with more information. When I click on that link, nothing happens. Just checked again, the link in the error message is:

https://fedoraproject.org/wiki/PackageKit_Items_Not_Found#Missing_Package

I can copy it with a right click. Not sure why it does not open the browser when I left click, though.

Comment 4 Kalev Lember 2018-03-15 06:34:23 UTC
I'm pretty sure it's failing for you because fedora-cisco-openh264 is skip_if_unavailable=False + enabled_metadata=1 which makes the packagekitd in F28 stable crash at startup (fixed in https://bodhi.fedoraproject.org/updates/FEDORA-2018-5ebe0eb1f2) and then gnome-software fails silently without getting any results back from packagekit.

Langpack installation works for me here with disabled fedora-cisco-openh264: https://kalev.fedorapeople.org/libreoffice-langpacks.webm

Also clicking on the error link works for me here. I believe there was a mutter bug with link opening, also fixed in https://bodhi.fedoraproject.org/updates/FEDORA-2018-5ebe0eb1f2

Comment 5 Kalev Lember 2018-03-15 13:39:54 UTC
I nominated https://bugzilla.redhat.com/show_bug.cgi?id=1544193 (openh264 repo issue) as a F28 Beta blocker now. The rest of the issues here seem already fixed up, so let's close this ticket. Thanks for testing it, Till!


Note You need to log in before you can comment on or make changes to this bug.