Bug 155586 - can't find /usr/lib/libltdl.la creating plugin
can't find /usr/lib/libltdl.la creating plugin
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-21 12:50 EDT by Harald Hoyer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 11:02:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2005-04-21 12:50:48 EDT
I have to specify '-shrext .so' to let libtool create the dlo's with .so
This should be the default on linux!

libtool-1.5.14.multilib2-6

Also libtool should say that it needs the package
libtool-ltdl-devel-1.5.14.multilib2-6
to compile plugins! The error message is that it can't find /usr/lib/libltdl.la
Comment 1 Harald Hoyer 2005-04-21 12:58:32 EDT
Oh, I take the .so problem back... it was a packages own 'libtool' ... thought
libtoolize --copy --force would overwrite it.

Comment 2 Alexandre Oliva 2005-04-27 11:39:36 EDT
There's little we can do about fixing broken copies of libtool in upstream
packages, other than talking upstream developers into updating the copy of
libtool they use, and overriding libtool as you've done in the meantime.

As for needing libltdl.la for plugins, what is it that you're trying to do
(command line), and how does it fail (error output)?  AFAIK it shouldn't be
necessary to have libltdl.la to create a plugin (as opposed to a program that
uses libltdl), unless you're linking with some other libtool library that was
linked with libltdl itself.

libtool never brings in libltdl by itself, any time it's linked in, it's either
because it was explicitly specified in the command line, or because some other
library you're linking with was linked with it.  So it would be this other
library's responsibility to make sure that libltdl.la is available whenever its
own .la file is present.
Comment 3 Karsten Hopp 2005-09-08 11:02:55 EDT
Not libtools bug, the 'other library' needs to make sure libltdl is installed

Note You need to log in before you can comment on or make changes to this bug.