Bug 1556732 - rdoc crashes when expression contains embedded comment: no implicit conversion of nil into String (TypeError)
Summary: rdoc crashes when expression contains embedded comment: no implicit conversio...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-rdoc
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1528846
Blocks: 1556412
TreeView+ depends on / blocked
 
Reported: 2018-03-15 07:14 UTC by Dan Callaghan
Modified: 2018-03-30 13:16 UTC (History)
3 users (show)

Fixed In Version: rubygem-rdoc-6.0.2-1.fc29 rubygem-rdoc-6.0.2-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-30 13:16:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ruby 14617 None None None 2018-03-19 11:41:57 UTC

Description Dan Callaghan 2018-03-15 07:14:41 UTC
Description of problem:
This crash happens during the rdoc build of the rubygem-sup package which causes it to FTBFS (bug 1556412). See that bug for a complete stack trace.

This is also filed upstream as:
https://github.com/ruby/rdoc/issues/585

Version-Release number of selected component (if applicable):
rubygem-rdoc-6.0.1-90.fc29.noarch

How reproducible:
somewhat easily

Steps to Reproduce:
see minimal reproducer in https://github.com/ruby/rdoc/issues/585#issuecomment-357513625

Actual results:
error generating Redwood/ThreadViewMode.html: no implicit conversion of nil into String (TypeError)

Expected results:
should produce docs successfully

Additional info:
According to the upstream issue, a fix is merged to master but not in any release yet:
https://github.com/ruby/rdoc/pull/586

Comment 1 Vít Ondruch 2018-03-19 11:41:57 UTC
Hi Dan,

Thx for the analysis and report of this issue. I'll try to get back to it, but meanwhile, I asked Ruby upstream to backport the fix.

Comment 2 Vít Ondruch 2018-03-22 11:14:51 UTC
SHould be resolved now, since I was able to scratch build rubygem-sup

Comment 3 Dan Callaghan 2018-03-22 22:50:40 UTC
Thanks! It is indeed fixed in rawhide.

But this bug actually exists in F28 as well, with rubygem-rdoc-5.1.0-3.fc28. Sorry, I should have filed it against F28 in the first place. Is it possible to backport this fix to F28?

Comment 4 Fedora Update System 2018-03-23 09:25:08 UTC
rubygem-rdoc-6.0.2-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c20ac1671a

Comment 5 Vít Ondruch 2018-03-23 09:27:43 UTC
I submitted the update and override for F28:

~~~
$ bodhi overrides save rubygem-rdoc-6.0.2-1.fc28 --notes "Needed by rubygem-sup"
============================================================
     rubygem-rdoc-6.0.2-1.fc28
============================================================
  Submitter: vondruch
  Expiration Date: 2018-03-30 09:26:01
  Notes: Needed by rubygem-sup
  Expired: False


Use the following to ensure the override is active:

	$ koji wait-repo f28-build --build=rubygem-rdoc-6.0.2-1.fc28
~~~

Comment 6 Fedora Update System 2018-03-23 14:45:51 UTC
rubygem-rdoc-6.0.2-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c20ac1671a

Comment 7 Dan Callaghan 2018-03-25 22:45:08 UTC
Thanks!

Comment 8 Fedora Update System 2018-03-30 13:16:00 UTC
rubygem-rdoc-6.0.2-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.