Bug 1556955 - Impossible to manipulate MTU from undercloud (openstack network create/set)
Summary: Impossible to manipulate MTU from undercloud (openstack network create/set)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Julie Pichon
QA Contact: Shai Revivo
URL:
Whiteboard:
: 1559051 (view as bug list)
Depends On:
Blocks: 1546994
TreeView+ depends on / blocked
 
Reported: 2018-03-15 15:39 UTC by Roee Agiman
Modified: 2018-06-27 13:47 UTC (History)
9 users (show)

Fixed In Version: python-openstackclient-3.14.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:46:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 556545 None MERGED neutron: add --mtu for create/set network 2020-08-19 00:03:38 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:47:44 UTC

Description Roee Agiman 2018-03-15 15:39:46 UTC
Description of problem:
There is no option to manipulate MTU upon creating/setting network from UC.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Deploy OSP13
2.Execute 'openstack network create --help' | grep -i mtu
3.Option missing

Actual results:
Missing MTU manipulation option

Expected results:
MTU option is available

Additional info:

Comment 1 Ihar Hrachyshka 2018-03-15 16:13:22 UTC
I forgot to add support for the field to openstackclient when implementing the feature in neutron. The old neutronclient should work as-is because it allows to pass unknown fields, but openstackclient requires specific changes to allow the attribute to pass through to the server.

Comment 2 Brian Haley 2018-03-15 17:12:04 UTC
See https://review.openstack.org/#/c/553374/ which proposed adding --mtu to the openstackclient just this morning.

Comment 4 Ihar Hrachyshka 2018-03-26 14:27:26 UTC
Queens backport: https://review.openstack.org/#/c/556545/

Comment 5 Ihar Hrachyshka 2018-04-04 14:27:10 UTC
The fix is included in 3.14.1. We just need to check the rebase happened.

Comment 7 Julie Pichon 2018-04-05 13:36:48 UTC
*** Bug 1559051 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2018-06-27 13:46:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.