Bug 1556963 - "oc login --help" formatting issue
Summary: "oc login --help" formatting issue
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Maciej Szulik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks: 1724792
TreeView+ depends on / blocked
 
Reported: 2018-03-15 15:56 UTC by Thom Carlin
Modified: 2019-08-08 02:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-04 09:01:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1635 None None None 2019-07-04 09:01:33 UTC

Description Thom Carlin 2018-03-15 15:56:28 UTC
Description of problem:

The options displayed by "oc login --help" is missing a newline

Version-Release number of selected component (if applicable):

atomic-openshift-clients-3.7.23-1.git.0.8edc154.el7.x86_64

How reproducible:

100%

Steps to Reproduce:
1. oc login --help

Actual results:

[...]
Options:
  -p, --password='': Password, will prompt if not provided
  -u, --username='': Username, will prompt if not provided      --certificate-authority='': Path to a cert file for the
certificate authority
      --insecure-skip-tls-verify=false: If true, the server's certificate will not be checked for validity. This will
make your HTTPS connections insecure
      --token='': Bearer token for authentication to the API server
[...]

Expected results:

[...]
Options:
  -p, --password='': Password, will prompt if not provided
  -u, --username='': Username, will prompt if not provided
      --certificate-authority='': Path to a cert file for the
certificate authority
      --insecure-skip-tls-verify=false: If true, the server's certificate will not be checked for validity. This will
make your HTTPS connections insecure
      --token='': Bearer token for authentication to the API server
[...]

Additional info:

Also see: man oc-login

Comment 2 Maciej Szulik 2019-02-27 21:40:35 UTC
Fix in https://github.com/openshift/origin/pull/22182

Comment 4 Xingxing Xia 2019-06-28 06:12:06 UTC
Verified in oc v4.1.4-201906261555

Comment 7 errata-xmlrpc 2019-07-04 09:01:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1635


Note You need to log in before you can comment on or make changes to this bug.