Bug 155701 - libgcc %post script failure for Raw Hide kickstart
libgcc %post script failure for Raw Hide kickstart
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2005-04-22 08:45 EDT by Joe Orton
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.0.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 16:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2005-04-22 08:45:58 EDT
Installing libgcc-4.0.0-0.42.i386.
error: %post(libgcc-4.0.0-0.42.i386) scriptlet failed, exit status 0

though I'm not sure what kind of "failure" exit status 0 is exactly...
Comment 1 Jakub Jelinek 2005-04-24 07:25:40 EDT
Is this on ia64 with ia32el not installed or something?
Comment 2 Joe Orton 2005-04-24 09:07:29 EDT
No, perfectly normal x86 installation.
Comment 3 Jakub Jelinek 2005-04-26 07:05:46 EDT
Sounds like rpm bug anyway.  There were no changes to the libgcc's %post
since mid February and all that binary does is access /sbin/ldconfig and
execl /sbin/ldconfig if it exists.
If you run /usr/sbin/libgcc_post_upgrade; echo $?
by hand, does it print 0?
Comment 4 Joe Orton 2005-04-28 13:13:54 EDT
[root@trash ~]# /usr/sbin/libgcc_post_upgrade
[root@trash ~]# echo $?
0
[root@trash ~]# rpm -q libgcc
libgcc-4.0.0-1

still saw this with on a kickstart of this morning's Raw Hide snapshot

rpm-4.4.1-11
anaconda-10.2.0.55-1
Comment 5 Jeremy Katz 2005-05-06 13:07:44 EDT
Back to gcc...  mv /sbin/ldconfig /sbin/ldconfig.old ; /usr/sbin/libgcc_post_upgrade

Watch it segfault :-)
Comment 6 Jakub Jelinek 2005-05-16 16:24:26 EDT
Should be fixed in libgcc-4.0.0-5.

Note You need to log in before you can comment on or make changes to this bug.