Bug 1557036 - Environments upgraded to 3.9 and running external etcd hosts cannot install service catalog
Summary: Environments upgraded to 3.9 and running external etcd hosts cannot install s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.9.z
Assignee: Michael Gugino
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-15 20:13 UTC by Scott Dodson
Modified: 2018-05-17 06:43 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-17 06:42:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1546365 None CLOSED [free-int] kube-service-catalog/apiserver pod in crash loop after upgrade 2019-05-21 14:30:18 UTC
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:43:12 UTC

Internal Links: 1546365

Description Scott Dodson 2018-03-15 20:13:28 UTC
Description of problem:
Upgraded environments running w/ external etcd hosts cannot install service catalog.

This bug is forked form https://bugzilla.redhat.com/show_bug.cgi?id=1546365

Steps to Reproduce:
1. Install 3.7 using GA openshift-ansible (3.7.23 or earlier) with external etcd hosts
2. Upgrade to 3.9
3. Install Service Catalog

Actual results:
service catalog cannot reach etcd as it's misconfigured

Expected results:
service catalog works

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Michael Gugino 2018-03-15 20:18:28 UTC
PR for 3.9 created here: https://github.com/openshift/openshift-ansible/pull/7542

Comment 2 Russell Teague 2018-03-16 12:28:42 UTC
*** Bug 1556739 has been marked as a duplicate of this bug. ***

Comment 3 Weihua Meng 2018-04-10 08:23:44 UTC
Not fixed.

openshift-ansible-3.9.19-1.git.0.34f4090.el7.noarch
PR in this rpm

Steps:
1. install OCP 3.7.23 with external etcd, service catalog disabled
2. upgarde to 3.9.19
3. Install Service Catalog
Failed


[root@qe-wmeng37233etcd-master-1 ~]# oc logs po/apiserver-fxmjs
I0409 08:52:00.681033       1 feature_gate.go:184] feature gates: map[OriginatingIdentity:true]
I0409 08:52:00.681163       1 hyperkube.go:188] Service Catalog version v3.9.19 (built 2018-04-04T18:30:26Z)
E0409 08:52:00.681179       1 options.go:136] Error validating etcd options, do you have `--etcd-servers localhost` set?
Error: --etcd-servers must be specified

NAME                          READY     STATUS             RESTARTS   AGE
po/apiserver-fxmjs            0/1       CrashLoopBackOff   6          9m
po/controller-manager-99k45   1/1       Running            2          9m

[root@qe-wmeng37233etcd-master-1 ~]# oc describe po/apiserver-fxmjs

    Command:
      /usr/bin/service-catalog
    Args:
      apiserver
      --storage-type
      etcd
      --secure-port
      6443
      --etcd-servers
      
      --etcd-cafile
      /etc/origin/master/master.etcd-ca.crt
      --etcd-certfile
      /etc/origin/master/master.etcd-client.crt
      --etcd-keyfile
      /etc/origin/master/master.etcd-client.key
      -v
      10
      --cors-allowed-origins
      localhost
      --admission-control

Comment 4 Michael Gugino 2018-04-10 20:42:41 UTC
PR Created in master: https://github.com/openshift/openshift-ansible/pull/7887

Comment 5 Scott Dodson 2018-04-11 13:53:15 UTC
release-3.9 backport https://github.com/openshift/openshift-ansible/pull/7915

Comment 6 Weihua Meng 2018-04-16 09:46:30 UTC
Fixed.
openshift-ansible-3.9.22-1.git.0.2e15102.el7.noarch

NAME                       READY     STATUS    RESTARTS   AGE
apiserver-5br6s            1/1       Running   0          6m
controller-manager-4699t   1/1       Running   0          6m


      --etcd-servers
      https://qe-wmengr755-3723etcd-etcd-1:2379

Comment 10 errata-xmlrpc 2018-05-17 06:42:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.