Bug 1557472 - Anaconda installing in text mode fails to report errors to Bugzilla.
Summary: Anaconda installing in text mode fails to report errors to Bugzilla.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-simpleline
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiri Konecny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
Depends On:
Blocks: F28BetaFreezeException F28FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-03-16 15:57 UTC by Lukas Ruzicka
Modified: 2018-04-18 15:14 UTC (History)
12 users (show)

Fixed In Version: python-simpleline-1.1-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 15:14:42 UTC
Type: Bug


Attachments (Terms of Use)
Anaconda log (12.49 KB, text/plain)
2018-03-16 15:58 UTC, Lukas Ruzicka
no flags Details
Dnf librepo log (182.54 KB, text/plain)
2018-03-16 15:58 UTC, Lukas Ruzicka
no flags Details
Hawkey log (2.61 KB, text/plain)
2018-03-16 15:59 UTC, Lukas Ruzicka
no flags Details
Program log (37.56 KB, text/plain)
2018-03-16 15:59 UTC, Lukas Ruzicka
no flags Details
Syslog (236.77 KB, text/plain)
2018-03-16 15:59 UTC, Lukas Ruzicka
no flags Details
Screenshot (34.64 KB, image/png)
2018-03-16 16:00 UTC, Lukas Ruzicka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1541868 unspecified CLOSED Unuseful log lines reporting bugs 2020-10-14 00:28:05 UTC

Internal Links: 1541868

Description Lukas Ruzicka 2018-03-16 15:57:48 UTC
Description of problem:

When proceeding with this test case [1], I tried to kill Anaconda running in text mode to use the automatic reporting to Bugzilla. Anaconda crashed in with a traceback. In graphical mode, the error was correctly reported.

Version-Release number of selected component (if applicable):

anaconda 28.22.2-1.fc28

How reproducible:

Always

Steps to Reproduce:
1. Start Anaconda in text mode (using inst.text on prompt)
2. Kill it according to the test case using 
kill -USR1 `cat /var/run/anaconda.pid`
3. Chose options to report the bug.
3. Save the report file using :wq
4. Wait for Anaconda to crash.

Actual results:

Anaconda crashes with the traceback, see screenshot.

Expected results:

Anaconda should be able to report the bug correctly to Bugzilla.

Additional info:

[1] https://fedoraproject.org/wiki/QA:Testcase_Anaconda_save_traceback_to_bugzilla

Comment 1 Lukas Ruzicka 2018-03-16 15:58:24 UTC
Created attachment 1408897 [details]
Anaconda log

Comment 2 Lukas Ruzicka 2018-03-16 15:58:49 UTC
Created attachment 1408898 [details]
Dnf librepo log

Comment 3 Lukas Ruzicka 2018-03-16 15:59:11 UTC
Created attachment 1408899 [details]
Hawkey log

Comment 4 Lukas Ruzicka 2018-03-16 15:59:34 UTC
Created attachment 1408900 [details]
Program log

Comment 5 Lukas Ruzicka 2018-03-16 15:59:56 UTC
Created attachment 1408901 [details]
Syslog

Comment 6 Lukas Ruzicka 2018-03-16 16:00:31 UTC
Created attachment 1408902 [details]
Screenshot

Comment 7 Fedora Blocker Bugs Application 2018-03-16 16:02:16 UTC
Proposed as a Blocker for 28-beta by Fedora user lruzicka using the blocker tracking app because:

 This bug affects the Basic Release Criteria. The installer must be able to report failures to Bugzilla, with appropriate information included.

Comment 8 Adam Williamson 2018-03-19 20:58:41 UTC
a6200-280 $33.40

Discussed at 2018-03-19 Fedora 28 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-03-19/f28-blocker-review.2018-03-19-16.02.html . As the report is actually failed, but anaconda crashes before displaying the URL, we decided this wasn't a serious enough violation to constitute a Beta blocker, but it is serious enough to constitute a Final blocker. We also accepted it as a freeze exception issue for Beta, as obviously it'd be good to fix this if possible.

Comment 9 Adam Williamson 2018-03-19 21:03:13 UTC
Siiiiigh. Serves me right for using the same scratch text file for a) blocker secretary work and b) air conditioner maintenance. :P

Comment 10 Jiri Konecny 2018-03-20 11:54:21 UTC
Based on my discover the proper fix should be done in Simpleline.

Comment 11 Adam Williamson 2018-04-02 16:49:07 UTC
Jiri - any news on this? It's blocking Final, and we're coming up on Final now. Freeze is in a couple of weeks. Thanks!

Comment 12 Jiri Konecny 2018-04-03 08:11:33 UTC
Work in progress.

PR: https://github.com/rhinstaller/python-simpleline/pull/51

Sorry I forgot to move it to post.

Comment 13 Adam Williamson 2018-04-17 22:41:16 UTC
This was actually included in https://bodhi.fedoraproject.org/updates/FEDORA-2018-205aabf6cb , but it wasn't tagged. We just need to confirm whether the fix worked, then we can close this.

Comment 14 Alessio 2018-04-18 11:09:24 UTC
On 20180415.n.0 compose, I can confirm that it works and the bug is created correctly.

However take into account this bug 1541868

Thanks

Comment 15 Lukas Ruzicka 2018-04-18 13:59:25 UTC
I also tested this and it works and reports the bug correctly. However, the bug Alessio speaks about in Comment 14 is still relevant. The fuzz is still produced.

Comment 16 Adam Williamson 2018-04-18 15:14:42 UTC
Thanks for the confirmation, Alessio, Lukas. I think the spam would be an FE issue not a blocker one, unfortunately doesn't look like anyone has picked it up to work on yet :( I'll poke the libreport folks and see if anything drops loose.

Since reporting does actually work now, we can close this one.


Note You need to log in before you can comment on or make changes to this bug.