Bug 1557485 - Anaconda is unable to allocate requested partition scheme on s390x if reqpart is present in kickstart
Summary: Anaconda is unable to allocate requested partition scheme on s390x if reqpart...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.5
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Vendula Poncova
QA Contact: Release Test Team
Sharon Moroney
URL:
Whiteboard:
Depends On:
Blocks: 1477564 1557360
TreeView+ depends on / blocked
 
Reported: 2018-03-16 16:33 UTC by Jan Stodola
Modified: 2018-10-30 07:55 UTC (History)
5 users (show)

Fixed In Version: anaconda-21.48.22.135-1
Doc Type: Bug Fix
Doc Text:
The "reqpart" Kickstart command will now only create partitions that are required by the hardware platform Previously, when the "reqpart" command was specified in a Kickstart file and no partitions were required by the hardware platform, the installer attempted to perform automatic partitioning. As a result, the installation failed with an error. This update ensures that the "reqpart" Kickstart command will only create partitions that are required by the hardware platform.
Clone Of:
Environment:
Last Closed: 2018-10-30 07:52:43 UTC


Attachments (Terms of Use)
program.log (47.16 KB, text/plain)
2018-03-16 16:35 UTC, Jan Stodola
no flags Details
storage.log (96.24 KB, text/plain)
2018-03-16 16:35 UTC, Jan Stodola
no flags Details
kickstart (248 bytes, text/plain)
2018-03-16 16:36 UTC, Jan Stodola
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3035 None None None 2018-10-30 07:55:12 UTC

Description Jan Stodola 2018-03-16 16:33:13 UTC
Description of problem:
When running kickstart installation on s390x and reqpart is specified in the ks file, anaconda fails to create requested partition scheme. The partitioning part of the ks file:

bootloader --location=mbr
zerombr
clearpart --all --initlabel

reqpart
part / --size=4000
part swap --fstype=swap --size=1000



Version-Release number of selected component (if applicable):
RHEL-7.5 / s390x
anaconda-21.48.22.134-1.el7
python-blivet-0.61.15.69-1.el7

How reproducible:
always on s390x

Steps to Reproduce:
1. run kickstart installation with the partitioning defined above

Actual results:
[   45.627288] anaconda[1718]: Starting installer, one moment...                
[   45.627577] anaconda[1718]: anaconda 21.48.22.134-1 for Red Hat Enterprise Li
nux 7.5 started.                                                                
[   45.627765] anaconda[1718]: * installation log files are stored in /tmp durin
g the installation                                                              
[   45.627952] anaconda[1718]: * when reporting a bug add logs from /tmp as sepa
rate text/plain attachments                                                     
[   45.628145] anaconda[1718]: 16:02:13 Not asking for VNC because of an automat
ed install                                                                      
[   45.628996] anaconda[1718]: 16:02:13 Not asking for VNC because text mode was
 explicitly asked for in kickstart                                              
[   58.103369] anaconda[1718]: Starting automated install.......                
[   58.103813] anaconda[1718]: Checking software selection                      
[   58.104001] anaconda[1718]: Generating updated storage configuration         
[   58.104189] anaconda[1718]: storage configuration failed: Unable to allocate 
requested partition scheme.

Expected results:
Successful installation. No other partition is created by reqpart, since it's not needed on s390x.

Comment 3 Jan Stodola 2018-03-16 16:35:14 UTC
Created attachment 1408925 [details]
program.log

Comment 4 Jan Stodola 2018-03-16 16:35:36 UTC
Created attachment 1408926 [details]
storage.log

Comment 6 Jan Stodola 2018-03-16 16:36:18 UTC
Created attachment 1408928 [details]
kickstart

Comment 7 Vendula Poncova 2018-04-10 13:04:45 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1424

Comment 9 Jan Stodola 2018-07-04 15:14:06 UTC
Verified with anaconda-21.48.22.143-2.el7 using the steps from the bug description and this bug is fixed.

Thanks, moving to VERIFIED.

Comment 14 errata-xmlrpc 2018-10-30 07:52:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3035


Note You need to log in before you can comment on or make changes to this bug.