Bug 155756 - "valknut" applications messes things up
"valknut" applications messes things up
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2005-04-22 15:51 EDT by Marius Andreiana
Modified: 2014-06-18 05:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 10:56:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xwininfo.txt (85.47 KB, text/plain)
2005-05-13 17:16 EDT, Marius Andreiana
no flags Details
xprop-desktop (16.71 KB, text/plain)
2005-05-13 17:17 EDT, Marius Andreiana
no flags Details
xprop-panel (17.51 KB, text/plain)
2005-05-13 17:18 EDT, Marius Andreiana
no flags Details
xprop-valknut (1.51 KB, text/plain)
2005-05-13 17:23 EDT, Marius Andreiana
no flags Details
metacity.log (164.78 KB, application/octet-stream)
2005-09-01 13:26 EDT, Marius Andreiana
no flags Details

  None (edit)
Description Marius Andreiana 2005-04-22 15:51:16 EDT
In fc4t2, with development xorg/gtk/gnome updated, panel and windows
disappear from time to time. alt+tab shows icons for all windows opened,
but after switching to a window it's not displayed. Sometimes clicking
in a window makes it disappear. After some random clicks and desktop switching
the normal behavior resumes, for a while.

I cannot reproduce this. Once this happens, it always repeats in a session.
Restarting PC solves it.

Another observation: after clicking a window in window list applet
sometimes it appears only after moving the mouse pointer outside of
panel.

When/if this happens again, what info could I gather to help debug it?
Comment 1 Marius Andreiana 2005-05-11 06:33:13 EDT
This still happens with current development updates and FC4 final is close.
Increasing severity.
Comment 2 Ray Strode [halfline] 2005-05-11 16:47:38 EDT
This will be hard to fix without being able to reproduce it.  Do you have any
idea what triggers it to happen?
Comment 3 Ray Strode [halfline] 2005-05-11 16:48:21 EDT
Also, how frequently does it happen for you?
Comment 4 Marius Andreiana 2005-05-12 04:32:37 EDT
I thought it's because of applications having icons in notification area (like
gaim with system tray plugin), which hide/show their windows by clicking on the
icon, but I can't reproduce :(

I have several programs in saved session (evolution, epiphany, gedit,
gnome-terminal) on different desktops.
Everything works after startup.
Then I started gaim with system-tray plugin (in notification applet), all is ok.
Started ed2k-gui, all ok (this has an icon in notification area too). This isn't
in fedora core and uses GTK.
Started valknut, all ok (this has an icon in notification area too). This isn't
in fedora core and uses QT.

From here on I used these and switch between desktops and windows when bug
occured (the 'light' version of bug). There are two buggy behaviors:
1. When switching windows by clicking in the Window list applet, the new window
with focus doesn't appear until the mouse pointer leaves the window list applet
area (or the panel? I'll try this next time)
2. Besides 1, sometimes all windows and panel dissapear. I have only one panel.
Window icons are still shown on ALT+tab, but they don't appear on desktop. 

Logout and login again fixes this.

Next time it happens I'll try to reproduce what I did before bug. Do you have
any suggestions what to do after the bug occured and might help with debugging?

Frequency: I have 8-10 hour sessions. By the end of the day, bug is usually
triggered (>75% of time).
Comment 5 Marius Andreiana 2005-05-12 13:40:44 EDT
About 1, new window will appear when mouse pointer will leave the panel, not
only the window list applet.
Comment 6 Matthias Clasen 2005-05-13 10:22:51 EDT
One thing that might help understand what  is going on is to see the output of
xwininfo -root -tree and maybe the output of xprop on the desktop background 
window.

You could also consider running metacity from a terminal with debug output
to see if it seems to get confused at some point.
Comment 7 Marius Andreiana 2005-05-13 17:16:24 EDT
Created attachment 114357 [details]
xwininfo.txt
Comment 8 Marius Andreiana 2005-05-13 17:17:19 EDT
Created attachment 114358 [details]
xprop-desktop
Comment 9 Marius Andreiana 2005-05-13 17:18:50 EDT
Created attachment 114359 [details]
xprop-panel
Comment 10 Marius Andreiana 2005-05-13 17:23:18 EDT
Created attachment 114360 [details]
xprop-valknut

xprop for "valknut" application, this seems buggy. Now on some workspaces it
shows both the icon in Notification applet, but also a tab in Window list
applet (nothing appears when clicking it), and on other workspaces it doesn't
show none of them.
Comment 11 Marius Andreiana 2005-05-13 17:28:01 EDT
How should I run metacity with debugging output?
metacity --help
metacity [--sm-disable] [--sm-client-id=ID] [--sm-save-file=FILENAME]
[--display=DISPLAY] [--replace] [--version]

Note that running "killall metacity" will restart it with correct behaviour
(including valknut which is back to normal).

I should modify ~/.gnome2/session RestartCommand for metacity to include
debugging in a file? What's that command?

Thanks
Comment 12 Ray Strode [halfline] 2005-05-13 17:50:59 EDT
in a terminal you can run

metacity --replace >& metacity.log &
metacity-message toggle-verbose
disown

to create a file called metacity.log with debug spew.  It will fill up very
quickly though.
Comment 13 Marius Andreiana 2005-09-01 13:25:01 EDT
Hello Ray,

Sorry for the lack of feedback. I'm replicating this now on FC4 updated.
I've found the cause to be an QT application called "valknut". However, even if
it has bad code, it shouldn't affect metacity so bad?

Attached is the log you required. I turned on logging before starting valknut,
and then the bug appeared (the light version of it).
Comment 14 Marius Andreiana 2005-09-01 13:26:41 EDT
Created attachment 118358 [details]
metacity.log
Comment 15 Elijah Newren 2006-01-21 16:40:01 EST
This looks like upstream #311868; could you try the attached patch in that bug
and tell me the terminal output that you get?
Comment 16 Marius Andreiana 2006-01-22 02:57:07 EST
I cannot recompile metacity. I can test a rpm for fc5 development (still happens
there, the bug is triggered by starting valknut QT application at ~50% of the
cases). killall metacity will bring the good behaviour back.
Comment 17 Søren Sandmann Pedersen 2006-09-07 20:58:31 EDT
Do you still see this problem?
Comment 18 Søren Sandmann Pedersen 2006-09-21 10:56:53 EDT
I can't reproduce this problem with valknut 3.7.0, so closing this bug. Feel
free to reopen if the problem still happens.

Note You need to log in before you can comment on or make changes to this bug.