Bug 1557775 - [RFE] During deployment, verification is missing for wrong NFS path.
Summary: [RFE] During deployment, verification is missing for wrong NFS path.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: RFEs
Version: 2.2.13
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.2.4
: 2.2.21
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: ovirt-hosted-engine-setup-2.2.22
TreeView+ depends on / blocked
 
Reported: 2018-03-18 14:48 UTC by Nikolai Sednev
Modified: 2018-06-26 08:41 UTC (History)
1 user (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.21
Doc Type: Bug Fix
Doc Text:
Add a preliminary check on NFS path syntax.
Clone Of:
Environment:
Last Closed: 2018-06-26 08:41:56 UTC
oVirt Team: Integration
sbonazzo: ovirt-4.2?
rule-engine: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91167 0 'None' MERGED ansible: nfs: preliminary path validation 2020-07-23 02:58:14 UTC
oVirt gerrit 91207 0 'None' MERGED ansible: nfs: preliminary path validation 2020-07-23 02:58:15 UTC

Description Nikolai Sednev 2018-03-18 14:48:31 UTC
Description of problem:
During deployment, verification is missing for wrong NFS path.
The deployment is not checking for correct NFS path and trying to proceed with incorrect values without checking, then fails.
Deployment should check for the correct path and if its fine, only then proceed with the deployment, otherwise to warn customer that provided path is incorrect.

[ INFO  ] TASK [Check host status]
[ INFO  ] skipping: [localhost]
[ INFO  ] TASK [Remove host-deploy configuration file]
[ INFO  ] changed: [localhost]
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: 
          Please specify the nfs version you would like to use (auto, v3, v4, v4_1)[auto]: 
          Please specify the full shared storage connection path to use (example: host:/path): Works for me on these components:
ovirt-hosted-engine-ha-2.2.7-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.13-1.el7ev.noarch
rhvm-appliance-4.2-20180202.0.el7.noarch
Linux 3.10.0-861.el7.x86_64 #1 SMP Wed Mar 14 10:21:01 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)
Deployed over iSCSI.          If needed, specify additional mount options for the connection to the hosted-engine storagedomain []: [ INFO  ] Creating Storage Domain
[ INFO  ] TASK [Gathering Facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [include_tasks]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Obtain SSO token using username/password credentials]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch host facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch cluster id]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch cluster facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch datacenter facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch datacenter id]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch datacenter_name]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Add nfs storage domain]
[ ERROR ] Error: Fault reason is "Incomplete parameters". Fault detail is "HostStorage [path] required for add". HTTP response code is 400.
[ ERROR ] fatal: [localhost]: FAILED! => {"changed": false, "msg": "Fault reason is \"Incomplete parameters\". Fault detail is \"HostStorage [path] required for add\". HTTP response code is 400."}
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: [ ERROR ] Invalid value
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: [ ERROR ] Invalid value
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: [ ERROR ] Invalid value
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: [ ERROR ] Invalid value
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: yellow-vdsb.qa.lab.tlv.redhat.com:/Compute_NFS/nsednev_he_2
[ ERROR ] Invalid value
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: 


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-2.2.7-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.13-1.el7ev.noarch
rhvm-appliance-4.2-20180202.0.el7.noarch
Linux 3.10.0-861.el7.x86_64 #1 SMP Wed Mar 14 10:21:01 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)
Deployed over iSCSI.          

How reproducible:
100%

Steps to Reproduce:
1.Deploy SHE over NFS and provide incorrect NFS path.

Actual results:
Deployment proceeds without any verification ov values.
 
Expected results:
The verification is missing.

Comment 1 Nikolai Sednev 2018-03-18 14:49:35 UTC
Deployment was made over ansible aka Node 0.

Comment 2 Nikolai Sednev 2018-06-04 15:19:01 UTC
Works for me on these components:
ovirt-hosted-engine-ha-2.2.13-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.22-1.el7ev.noarch
rhvm-appliance-4.2-20180601.0.el7.noarch
Red Hat Enterprise Linux Server release 7.5 (Maipo)
Linux 3.10.0-862.3.2.el7.x86_64 #1 SMP Tue May 15 18:22:15 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux


 INFO  ] changed: [localhost]
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: 
          Please specify the nfs version you would like to use (auto, v3, v4, v4_1)[auto]: 
          Please specify the full shared storage connection path to use (example: host:/path): [ ERROR ] Invalid value
[ ERROR ] Invalid connection path: [ ERROR ] Invalid value
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: Works for me on these components:
[ ERROR ] Invalid value
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: 


Moving to verified.

Comment 3 Sandro Bonazzola 2018-06-26 08:41:56 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.