Bug 1557909 - Changes needed for cfme-46 fully support
Summary: Changes needed for cfme-46 fully support
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.9.z
Assignee: Russell Teague
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Keywords:
: 1560893 (view as bug list)
Depends On:
Blocks: 1557234
TreeView+ depends on / blocked
 
Reported: 2018-03-19 08:55 UTC by Gaoyun Pei
Modified: 2018-05-17 06:43 UTC (History)
5 users (show)

(edit)
Removed beta acknowledgment due to CFME 4.6 is GA
Clone Of:
(edit)
Last Closed: 2018-05-17 06:42:42 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:43 UTC

Description Gaoyun Pei 2018-03-19 08:55:13 UTC
Description of problem:
To make full support for CFME-4.6 in OCP-3.9, we need the following changes in installer:

"openshift_management_install_beta"[1] should be removed for CFME-4.6 is GA and it's fully supported.

"openshift_management_app_template"[2] var declaration should be switched to the first one which is commented out.
 

[1]https://github.com/openshift/openshift-ansible/blob/openshift-ansible-3.9.11-1/roles/openshift_management/tasks/validate.yml#L5-L16
[2]https://github.com/openshift/openshift-ansible/blob/openshift-ansible-3.9.11-1/roles/openshift_management/defaults/main.yml#L18-L20



Version-Release number of the following components:
openshift-ansible-3.9.11-1.git.0.153fcff.el7.noarch


How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Russell Teague 2018-03-19 12:46:23 UTC
Proposed (master): https://github.com/openshift/openshift-ansible/pull/7566

Comment 2 N. Harrison Ripps 2018-03-19 14:05:25 UTC
This will be release noted for 3.9 and resolved in 3.9.z

Comment 3 openshift-github-bot 2018-03-21 19:12:43 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/a8578a28a8ca29822aa7842b7a733cf17f6b7239
Merge pull request #7566 from mtnbikenc/fix-1557909

Bug 1557909 - Remove openshift_management beta acknowledgement

Comment 4 Russell Teague 2018-03-21 19:23:06 UTC
release-3.9 PR: https://github.com/openshift/openshift-ansible/pull/7598

Comment 5 Scott Dodson 2018-03-29 01:32:26 UTC
*** Bug 1560893 has been marked as a duplicate of this bug. ***

Comment 6 Russell Teague 2018-04-02 18:29:16 UTC
Fix is in openshift-ansible-3.9.15-1

Comment 7 Gaoyun Pei 2018-04-03 06:45:37 UTC
Will verify this bug once openshift-ansible-3.9.15-1 rpm package is available

Comment 8 Gaoyun Pei 2018-04-08 06:11:48 UTC
Verify this bug with openshift-ansible-3.9.19-1.git.0.34f4090.el7.noarch

openshift_management_install_beta is no longer needed for cfme deployment and the default app_template is cfme-template for ocp now.

Comment 10 Gaoyun Pei 2018-04-23 05:53:30 UTC
Move it to verified according to Comment 8

Comment 13 errata-xmlrpc 2018-05-17 06:42:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.