Bug 1558113 - exceptions thrown in barbican-keystone-listener
Summary: exceptions thrown in barbican-keystone-listener
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-barbican
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Ade Lee
QA Contact: Pavan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-19 16:25 UTC by Ade Lee
Modified: 2018-06-27 13:49 UTC (History)
3 users (show)

Fixed In Version: openstack-barbican-6.0.1-0.20180421143301.b10e100.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:47:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1750333 None None None 2018-03-26 14:47:02 UTC
OpenStack gerrit 557067 None MERGED Initialize db for Barbican Keystone listener 2020-06-15 11:44:03 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:49:05 UTC

Description Ade Lee 2018-03-19 16:25:47 UTC
Description of problem:

Upstream issue: https://bugs.launchpad.net/barbican/+bug/1750333

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Harry Rybacki 2018-04-25 18:06:35 UTC
Upstream review[1] has merged. Moving bug to POST.

[1] - http://etherpad.corp.redhat.com/hrybacki-tmp-dfg-sec-sprint24-backport-scratchpad

Comment 10 Ade Lee 2018-05-02 14:47:56 UTC
Test Procedure:

1. Deploy an overcloud with barbican and barbican-keystone listener running
2. Create a new project and add a user to it
3. Create the creator role and associate that creator role with the project/user.
   This will allow you to create secrets
4. Create a secret as that user.  This will end up creating a project internally
   in barbican that corresponds to the keystone project.
5. Delete the keystone project.  At this point, keystone will emit a notification 
   that the project has been deleted.  This notification should be read by the 
   barbican keystone listener - which should then delete/de-activate the internal 
   barbican project.
6. Check the barbican-keystone-listener logs.  The project should be deleted
   without any exceptions thrown.

Comment 13 errata-xmlrpc 2018-06-27 13:47:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.