Bug 1558422 - do not delete node in openstack, if those still exist in cloudprovider
Summary: do not delete node in openstack, if those still exist in cloudprovider
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.7.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.9.z
Assignee: Seth Jennings
QA Contact: MinLi
URL:
Whiteboard:
Depends On:
Blocks: 1614849
TreeView+ depends on / blocked
 
Reported: 2018-03-20 08:20 UTC by Dmitry Zhukovski
Modified: 2018-08-21 02:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixes an issue where clusters running with Openstack cloud integration have nodes removed when the corresponding instance is stopped. Node resources whose instances are stopped are no longer removed from the cluster.
Clone Of:
: 1614849 (view as bug list)
Environment:
Last Closed: 2018-05-17 06:42:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:43:12 UTC

Description Dmitry Zhukovski 2018-03-20 08:20:59 UTC
Description of problem:
Deleting nodes in kubernetes cluster causes problems. It will lead to situations like labels and taints are missing from nodes when node will return online.

Version-Release number of selected component (if applicable):
3.7

How reproducible:
Always

Steps to Reproduce:
~~~ one of scenarios ~~~
egressips added to node hostsubnets using following command:
oc patch hostsubnet dc1-dev-node-1-101 -p '{"egressIPs": ["192.168.0.205", "192.168.0.206", "192.168.0.207", "192.168.0.208"]}'

Actual results:
After machine reboot by openstack API egress traffic does not work at all and egressips are missing from hostsubnet.

Expected results:
egressips are still within assigned hostsubnet

Additional info:
PR https://github.com/kubernetes/kubernetes/pull/59931 has been merged into K8s. We request to merge it in 3.10 and eventually backport to 3.9.z

Comment 5 Seth Jennings 2018-04-06 14:22:22 UTC
OSE 3.9 PR:
https://github.com/openshift/ose/pull/1194

Comment 7 weiwei jiang 2018-04-17 07:11:25 UTC
Checked with 
# oc version 
oc v3.9.22
kubernetes v1.9.1+a0ce1bc657
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://172.16.120.66:8443
openshift v3.9.22
kubernetes v1.9.1+a0ce1bc657

And after reboot, egressIP still existed in hostsubnet.

Comment 11 errata-xmlrpc 2018-05-17 06:42:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.