Bug 1558484 - Update of Egress Network Policy causes temporary egress failure when using dnsName
Summary: Update of Egress Network Policy causes temporary egress failure when using dn...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.7.0
Hardware: All
OS: Other
high
high
Target Milestone: ---
: 3.10.0
Assignee: Ravi Sankar
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-20 10:19 UTC by Andre Costa
Modified: 2018-07-30 19:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Update egress policy needed blocking outgoing traffic, patching ovs flows and then re-enabling traffic but the ovs flow generation for dns names was slow. Consequence: Few seconds egress traffic downtime which may not be acceptable. Fix: Change update egress policy handling to pre-populate all new ovs flows before blocking the outgoing traffic. Result: Reduces the downtime during egress policy updates.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:10:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:11:27 UTC
Github https://github.com/openshift origin pull 19346 None None None 2018-04-13 18:15:45 UTC

Description Andre Costa 2018-03-20 10:19:22 UTC
Description of problem:
Every 30 minutes the egress network policies are being updated/re-written (even when there is no change to any policy). As part of the process for the update to a policy in a project a drop rule is applied to the OpenFlow tables for the project with maximum priority and then the rules are rewritten. This means that for the duration of this rewrite no egress traffic is permitted from any pods in the project and no dns lookups are permitted either. We are seeing occasions where this re-write of rules can take the order of 5/6 seconds which potentially will impact our apps

The customer confirmed that redhat/ovs-multinant-pugin is configured on masters and nodes and followed the notes present on our documentation for this specific configuration:

https://docs.openshift.com/container-platform/3.7/admin_guide/managing_networking.html#admin-guide-limit-pod-access-egress


Expected results:
Control the EgressNetworkPolicies for being updated and/or not causing application downtime, since it seems traffic stops when the policies are updated.

Additional info:
OCP is using vSphere Cloud Provider.

I've been looking at this file:

https://raw.githubusercontent.com/openshift/origin/master/api/swagger-spec/oapi-v1.json

I don't see if there's any variable that would be useful to help with this or if there is something we can do to configure update timing or blocking it on the policy.json we can use to create the EgressNetworkPolicy object.

Also don't know if this might be related with this issue:

"Domain name updates are polled based on the TTL (time to live) value of the domain of the local non-authoritative server, or 30 minutes if the TTL is unable to be fetched. The pod should also resolve the domain from the same local non-authoritative server when necessary, otherwise the IP addresses for the domain perceived by the egress network policy controller and the pod will be different, and the egress network policy may not be enforced as expected. In the above example, suppose www.foo.com resolved to 10.11.12.13 and has a DNS TTL of one minute, but was later changed to 20.21.22.23. OpenShift Container Platform will then take up to one minute to adapt to these changes."

Comment 3 Ravi Sankar 2018-04-13 17:47:03 UTC
https://github.com/openshift/origin/pull/19346

Comment 7 Hongan Li 2018-05-23 03:20:48 UTC
verified in atomic-openshift-3.10.0-0.50.0.git.0.db6dfd6.el7, the ovs flow updated as below:
 
W0523 03:11:49.675710   32437 ovscontroller.go:473] Correcting CIDRSelector '0.0.0.0/32' to '0.0.0.0/0' in EgressNetworkPolicy lha:policy-test
I0523 03:11:49.675798   32437 ovs.go:155] Executing: ovs-ofctl -O OpenFlow13 bundle br0 - <<
flow delete table=101, reg0=5808747
flow add table=101, reg0=5808747, priority=2, ip, nw_dst=98.138.219.231, actions=output:2
flow add table=101, reg0=5808747, priority=2, ip, nw_dst=98.138.219.232, actions=output:2
flow add table=101, reg0=5808747, priority=2, ip, nw_dst=72.30.35.9, actions=output:2
flow add table=101, reg0=5808747, priority=2, ip, nw_dst=72.30.35.10, actions=output:2
flow add table=101, reg0=5808747, priority=2, ip, nw_dst=98.137.246.7, actions=output:2
flow add table=101, reg0=5808747, priority=2, ip, nw_dst=98.137.246.8, actions=output:2
flow add table=101, reg0=5808747, priority=1, ip, actions=drop

OS: Red Hat Enterprise Linux Server release 7.5 (Maipo)
kernel: Linux ip-172-18-8-142.ec2.internal 3.10.0-862.el7.x86_64 #1 SMP Wed Mar 21 18:14:51 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux

Comment 9 errata-xmlrpc 2018-07-30 19:10:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.