Bug 1558545 - additional files to grab during backup
Summary: additional files to grab during backup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Backup & Restore
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: Ranjan Kumar
URL:
Whiteboard:
: 1585755 (view as bug list)
Depends On:
Blocks: 1590754
TreeView+ depends on / blocked
 
Reported: 2018-03-20 13:01 UTC by Chris Duryee
Modified: 2019-09-26 16:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1572296 (view as bug list)
Environment:
Last Closed: 2018-06-19 20:17:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 22971 Normal Closed additional files to grab during backup 2020-03-31 10:11:45 UTC
Red Hat Product Errata RHBA-2018:1950 None None None 2018-06-19 20:17:33 UTC

Description Chris Duryee 2018-03-20 13:01:57 UTC
Description of problem:

As part of backup/restore, the following files should be pulled in:

/etc/crane.conf                                                       
/etc/default/pulp_workers                                             
/etc/mongod.conf                                                      
/etc/pki/ca-trust/                                                    
/etc/systemd/system/postgresql.service                                
/usr/local/bin/validate_postgresql_connection.sh                      
/usr/share/foreman-proxy/.ssh/                                        
/usr/share/ruby/vendor_ruby/puppet/reports/foreman.rb                 
/etc/sudoers.d/foreman-proxy                                          
/etc/sysconfig/foreman                                                
/usr/share/foreman/bundler.d/katello.rb                               
/etc/smart_proxy_dynflow_core/settings.yml                            
/etc/selinux/targeted/contexts/files/file_contexts.subs

After restore, you may need to do a "systemctl daemon-reload" to pick up the new postgresql.conf.


These files should also be in there:

    /var/lib/foreman # has files that get timestamps updated by installer
    /var/lib/puppet
    /var/lib/qpidd

Version-Release number of selected component (if applicable): 6.3.0

Comment 3 Brad Buckingham 2018-04-17 01:08:11 UTC
Moving to POST, since the upstream PR has been merged.

Comment 6 Ranjan Kumar 2018-06-12 09:06:51 UTC
Verified on satellite  6.3.2 Snap 2.0

All mentioned files are backed up and restored successfully

Comment 7 Chris Duryee 2018-06-12 21:03:19 UTC
*** Bug 1585755 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2018-06-19 20:17:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1950


Note You need to log in before you can comment on or make changes to this bug.