Bug 1558928 - [abrt] gnome-software: get_app_section(): gnome-software killed by SIGABRT
Summary: [abrt] gnome-software: get_app_section(): gnome-software killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:1d28284f921e9a8b9c1b98c6282...
: 1560293 1566589 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-21 10:31 UTC by Duncan Grisby
Modified: 2018-04-19 00:30 UTC (History)
7 users (show)

Fixed In Version: gnome-software-3.28.1-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-19 00:30:08 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (45.82 KB, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details
File: cgroup (292 bytes, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details
File: core_backtrace (21.24 KB, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details
File: cpuinfo (1.23 KB, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details
File: dso_list (19.09 KB, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details
File: environ (1.91 KB, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details
File: limits (1.29 KB, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details
File: maps (88.29 KB, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details
File: mountinfo (4.03 KB, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details
File: open_fds (3.46 KB, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details
File: proc_pid_status (1.28 KB, text/plain)
2018-03-21 10:32 UTC, Duncan Grisby
no flags Details

Description Duncan Grisby 2018-03-21 10:31:58 UTC
Description of problem:
I got a notification to say there was a software update available. It listed a number of items, including "OS Updates".

I clicked on "OS Updates" and it immediately crashed.

Version-Release number of selected component:
gnome-software-3.26.7-1.fc27

Additional info:
reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: get_app_section
executable:     /usr/bin/gnome-software
journald_cursor: s=86d9c54c29094d41a5c189faf6e74773;i=949a5b;b=24a008a49368451fbb06087b3c3c18d0;m=6c6d51c78a;t=567e99bfcf995;x=7adeb69773b7f97
kernel:         4.15.8-300.fc27.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Duncan Grisby 2018-03-21 10:32:05 UTC
Created attachment 1411135 [details]
File: backtrace

Comment 2 Duncan Grisby 2018-03-21 10:32:06 UTC
Created attachment 1411136 [details]
File: cgroup

Comment 3 Duncan Grisby 2018-03-21 10:32:09 UTC
Created attachment 1411137 [details]
File: core_backtrace

Comment 4 Duncan Grisby 2018-03-21 10:32:10 UTC
Created attachment 1411138 [details]
File: cpuinfo

Comment 5 Duncan Grisby 2018-03-21 10:32:12 UTC
Created attachment 1411139 [details]
File: dso_list

Comment 6 Duncan Grisby 2018-03-21 10:32:14 UTC
Created attachment 1411140 [details]
File: environ

Comment 7 Duncan Grisby 2018-03-21 10:32:16 UTC
Created attachment 1411141 [details]
File: limits

Comment 8 Duncan Grisby 2018-03-21 10:32:19 UTC
Created attachment 1411142 [details]
File: maps

Comment 9 Duncan Grisby 2018-03-21 10:32:21 UTC
Created attachment 1411143 [details]
File: mountinfo

Comment 10 Duncan Grisby 2018-03-21 10:32:22 UTC
Created attachment 1411144 [details]
File: open_fds

Comment 11 Duncan Grisby 2018-03-21 10:32:24 UTC
Created attachment 1411145 [details]
File: proc_pid_status

Comment 12 Duncan Grisby 2018-03-21 10:33:43 UTC
It happened again when I launched Software and clicked on OS Updates, so it is not a one-off error.

Comment 13 Kalev Lember 2018-03-21 12:38:37 UTC
Could you help debug this in gdb, please?

Something like this:

killall gnome-software
gdb gnome-software
r

# ... go and reproduce the crasher, and then type in gdb again:

bt full

# find the line that looks something like:
# #4  0x00005597397295ad in get_app_section (app=0x7f8b6450bca0) at ../src/gs-update-dialog.c:387
# (frame number #4 in this case), and then use that number in the next step:

frame 4
set print elements 0
set print repeats 0
p gs_app_to_string (app)

And then post all the output you got here, please?

Comment 14 Duncan Grisby 2018-03-21 12:56:19 UTC
I didn't have the debuginfo package installed, so I didn't get source lines:

(gdb) run
Starting program: /usr/bin/gnome-software 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffe37bd700 (LWP 29619)]
[New Thread 0x7fffe2fbc700 (LWP 29620)]
[New Thread 0x7fffe1f39700 (LWP 29621)]
[New Thread 0x7fffcc180700 (LWP 29622)]
[New Thread 0x7fffcb484700 (LWP 29629)]
[New Thread 0x7fffca20d700 (LWP 29634)]
[New Thread 0x7fffc9a0c700 (LWP 29635)]
[New Thread 0x7fffc920b700 (LWP 29636)]
[New Thread 0x7fffc8a0a700 (LWP 29637)]
[Thread 0x7fffc920b700 (LWP 29636) exited]
[Thread 0x7fffc9a0c700 (LWP 29635) exited]
[Thread 0x7fffca20d700 (LWP 29634) exited]
[New Thread 0x7fffca20d700 (LWP 29638)]
[New Thread 0x7fffc920b700 (LWP 29639)]
[New Thread 0x7fffc9a0c700 (LWP 29640)]
[New Thread 0x7fffbbfff700 (LWP 29641)]
[New Thread 0x7fffbb7fe700 (LWP 29642)]
[New Thread 0x7fffbaffd700 (LWP 29643)]
[Thread 0x7fffbaffd700 (LWP 29643) exited]
[Thread 0x7fffc8a0a700 (LWP 29637) exited]
**
Gs:ERROR:../src/gs-update-dialog.c:387:get_app_section: code should not be reached

Thread 1 "gnome-software" received signal SIGABRT, Aborted.
0x00007ffff3f87660 in raise () from /lib64/libc.so.6
(gdb) bt full
#0  0x00007ffff3f87660 in raise () at /lib64/libc.so.6
#1  0x00007ffff3f88c41 in abort () at /lib64/libc.so.6
#2  0x00007ffff745c65d in g_assertion_message () at /lib64/libglib-2.0.so.0
#3  0x00007ffff745c6ea in g_assertion_message_expr () at /lib64/libglib-2.0.so.0
#4  0x00005555555ac5ad in  ()
#5  0x00005555555acca8 in gs_update_dialog_show_update_details ()
#6  0x00005555555b017b in _app_row_activated_cb ()
#7  0x00007ffff770e73d in g_closure_invoke () at /lib64/libgobject-2.0.so.0
#8  0x00007ffff77214de in signal_emit_unlocked_R () at /lib64/libgobject-2.0.so.0
#9  0x00007ffff7729d05 in g_signal_emit_valist () at /lib64/libgobject-2.0.so.0
#10 0x00007ffff772a66f in g_signal_emit () at /lib64/libgobject-2.0.so.0
#11 0x00007ffff67691f0 in gtk_list_box_multipress_gesture_released () at /lib64/libgtk-3.so.0
#12 0x00007ffff2d74d1e in ffi_call_unix64 () at /lib64/libffi.so.6
#13 0x00007ffff2d7468f in ffi_call () at /lib64/libffi.so.6
#14 0x00007ffff770f32d in g_cclosure_marshal_generic_va () at /lib64/libgobject-2.0.so.0
#15 0x00007ffff770e976 in _g_closure_invoke_va () at /lib64/libgobject-2.0.so.0
#16 0x00007ffff7729ff4 in g_signal_emit_valist () at /lib64/libgobject-2.0.so.0
#17 0x00007ffff772a66f in g_signal_emit () at /lib64/libgobject-2.0.so.0
#18 0x00007ffff67280d1 in gtk_gesture_multi_press_end () at /lib64/libgtk-3.so.0
#19 0x00007ffff7711648 in g_cclosure_marshal_VOID__BOXEDv () at /lib64/libgobject-2.0.so.0
#20 0x00007ffff770e976 in _g_closure_invoke_va () at /lib64/libgobject-2.0.so.0
#21 0x00007ffff7729ff4 in g_signal_emit_valist () at /lib64/libgobject-2.0.so.0
#22 0x00007ffff772a66f in g_signal_emit () at /lib64/libgobject-2.0.so.0
#23 0x00007ffff672533e in _gtk_gesture_check_recognized () at /lib64/libgtk-3.so.0
#24 0x00007ffff672693b in gtk_gesture_handle_event () at /lib64/libgtk-3.so.0
#25 0x00007ffff672963e in gtk_gesture_single_handle_event () at /lib64/libgtk-3.so.0
#26 0x00007ffff66f6801 in gtk_event_controller_handle_event () at /lib64/libgtk-3.so.0
#27 0x00007ffff68baa2b in _gtk_widget_run_controllers () at /lib64/libgtk-3.so.0
#28 0x00007ffff6771b77 in _gtk_marshal_BOOLEAN__BOXEDv () at /lib64/libgtk-3.so.0
#29 0x00007ffff770e976 in _g_closure_invoke_va () at /lib64/libgobject-2.0.so.0
#30 0x00007ffff77299c9 in g_signal_emit_valist () at /lib64/libgobject-2.0.so.0
#31 0x00007ffff772a66f in g_signal_emit () at /lib64/libgobject-2.0.so.0
#32 0x00007ffff68bccd4 in gtk_widget_event_internal () at /lib64/libgtk-3.so.0
#33 0x00007ffff676ea4e in propagate_event () at /lib64/libgtk-3.so.0
#34 0x00007ffff6770b70 in gtk_main_do_event () at /lib64/libgtk-3.so.0
#35 0x00007ffff627e305 in _gdk_event_emit () at /lib64/libgdk-3.so.0
#36 0x00007ffff62afb22 in gdk_event_source_dispatch () at /lib64/libgdk-3.so.0
#37 0x00007ffff7435b77 in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#38 0x00007ffff7435f20 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#39 0x00007ffff7435fac in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#40 0x00007ffff70f1cad in g_application_run () at /lib64/libgio-2.0.so.0
#41 0x0000555555576436 in main ()


I don't see a get_app_section call, but maybe it was frame 4 that doesn't know what it is for some reason. Sadly I then exited gdb to install the debuginfo package. Running it again it said "no updates", so I hit the refresh button and it found a load of updates. Now when I click on "OS Updates" it does not crash. Sorry I can't reproduce it any more.

Comment 15 Kalev Lember 2018-03-21 13:11:37 UTC
OK, thanks for trying! I worked around the crash in https://gitlab.gnome.org/GNOME/gnome-software/commit/93a0b26428bcd7e881240683410ad53de63f9cd7 upstream, but if you happen to run into this again before you get the fixed version (upcoming 3.28.1 release), I'd be grateful if you could try the gdb commands again to understand what's really going on there.

Comment 16 Kazimieras Vaina 2018-03-22 13:06:44 UTC
Similar problem has been detected:

Attempt to look at system update detailt

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: get_app_section
executable:     /usr/bin/gnome-software
journald_cursor: s=f3365bc10cc34a86b733decf6940c9b3;i=252b5fd;b=2e2b5b0cce3c4289973786111b6c98b2;m=a0c1ec2a56;t=567ff76129b5f;x=a10314dc77e965bc
kernel:         4.15.8-300.fc27.x86_64
package:        gnome-software-3.26.7-1.fc27
reason:         gnome-software killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 17 jakob.jakobson18 2018-03-25 17:57:23 UTC
*** Bug 1560293 has been marked as a duplicate of this bug. ***

Comment 18 Krzysztof Troska 2018-04-04 07:15:56 UTC
Similar problem has been detected:

Clicked on OS Updateds, after os was updated and it should display all packaged which get updated.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: get_app_section
executable:     /usr/bin/gnome-software
journald_cursor: s=ccabf8db13304a5ba63083028162d970;i=18e6;b=6ab9e2b4611e464ab31ac38814304fb2;m=52eeb4fba;t=569006bf85579;x=d0ccb15baf591f1a
kernel:         4.15.13-300.fc27.x86_64
package:        gnome-software-3.26.7-1.fc27
reason:         gnome-software killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 19 ECHACHAGUA 2018-04-12 15:00:03 UTC
*** Bug 1566589 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2018-04-13 15:54:32 UTC
PackageKit-1.1.9-3.fc27 gnome-software-3.28.1-1.fc27 libappstream-glib-0.7.7-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-55a6726164

Comment 21 Fedora Update System 2018-04-13 15:56:59 UTC
PackageKit-1.1.9-3.fc27 gnome-software-3.28.1-1.fc27 libappstream-glib-0.7.7-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-55a6726164

Comment 22 Fedora Update System 2018-04-15 16:19:35 UTC
PackageKit-1.1.9-3.fc27, gnome-software-3.28.1-1.fc27, libappstream-glib-0.7.7-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-55a6726164

Comment 23 Fedora Update System 2018-04-19 00:30:08 UTC
PackageKit-1.1.9-3.fc27, gnome-software-3.28.1-1.fc27, libappstream-glib-0.7.7-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.