Bug 1558935 - should update "kubectl uncordon" to "oc adm uncordon" in "oc adm drain -h"
Summary: should update "kubectl uncordon" to "oc adm uncordon" in "oc adm drain -h"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Maciej Szulik
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-21 10:59 UTC by Weihua Meng
Modified: 2019-06-04 10:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:28 UTC

Description Weihua Meng 2018-03-21 10:59:41 UTC
Description of problem:
should update "kubectl uncordon" to "oc adm uncordon" in "oc adm drain -h"

Version-Release number of selected component (if applicable):
openshift v3.9.12

How reproducible:
Always

Steps to Reproduce:
1. oc adm drain -h

Actual results:
When you are ready to put the node back into service, use kubectl uncordon, which will make the node schedulable again.

Expected results:
When you are ready to put the node back into service, use oc adm uncordon, which will make the node schedulable again.

Comment 2 Maciej Szulik 2019-02-27 21:45:48 UTC
Fix in https://github.com/openshift/origin/pull/22183

Comment 3 Weihua Meng 2019-04-02 02:30:35 UTC
Fixed.

Release Metadata:
  Version:  4.0.0-0.alpha-2019-04-02-000616

Comment 5 errata-xmlrpc 2019-06-04 10:40:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.