Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1559108 - 6.3 upgrade causes missing Templates history
6.3 upgrade causes missing Templates history
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning Templates (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity high (vote)
: 6.3.2
: Unused
Assigned To: satellite6-bugs
Ranjan Kumar
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-21 13:19 EDT by Sean O'Keeffe
Modified: 2018-06-19 16:17 EDT (History)
7 users (show)

See Also:
Fixed In Version: foreman-1.15.6.41-1,foreman-1.15.6.44-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1572301 (view as bug list)
Environment:
Last Closed: 2018-06-19 16:17:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 22984 None None None 2018-03-22 07:33 EDT
Github /theforeman/foreman/pull/5632 None None None 2018-06-01 02:07 EDT
Red Hat Product Errata RHBA-2018:1950 None None None 2018-06-19 16:17 EDT

  None (edit)
Description Sean O'Keeffe 2018-03-21 13:19:32 EDT
Description of problem:

After upgrading to 6.3 i see no history for my provisioning template 


Version-Release number of selected component (if applicable):
6.3

How reproducible:
not sure


Steps to Reproduce:
1. build 6.2
2. create custom Provisioning Template
3. makes a change to that Template
4. check history tab for you change
5. Upgrade to 6.3
6. go to the history tab and no history will be displayed

Actual results:

no history is displayed

Expected results:

All previous history is displayed

Additional info:

It seems in 6.2 they were saved in the audit table as `:auditable_type => Template` whereas 6.3 they look like they are `:auditable_type => ProvisioningTemplate` and there has been no migration.




irb(main):028:0* Audit.descending.where(:auditable_id => 111, :auditable_type => Template, :action => 'update').count
=> 82
irb(main):029:0> Audit.descending.where(:auditable_id => 111, :auditable_type => Template, :action => 'update').first.created_at
=> Fri, 16 Mar 2018 15:46:56 UTC +00:00
irb(main):030:0> Audit.descending.where(:auditable_id => 111, :auditable_type => ProvisioningTemplate, :action => 'update').count
=> 2
irb(main):031:0> Audit.descending.where(:auditable_id => 111, :auditable_type => ProvisioningTemplate, :action => 'update').first.created_at
=> Wed, 21 Mar 2018 16:27:25 UTC +00:00

We upgraded on the morning of 21 Mar 2018
Comment 2 Sean O'Keeffe 2018-03-21 13:54:40 EDT
This looks like to be caused by https://github.com/theforeman/foreman/commit/5908bf418d28c57dcdc4d2e01ccf3253c0e8a81a I'm not sure why that migration was written like that? Or if they *should* be stored as ProvisioningTemplates or Templates?
Comment 6 pm-sat@redhat.com 2018-03-22 10:27:54 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/22984 has been resolved.
Comment 20 Ranjan Kumar 2018-06-12 02:01:01 EDT
Verified on satellite  6.3.2 2.0

Steps:
  1. Build Satellite 6.3.1
  2. Created new provisioning template
  3. modified the provisioning template
  4. Upgraded Satellite to 6.3.2 2.0

[root@rhel7-sat62-4 migrate]# rpm -qa | grep foreman
foreman-1.15.6.45-1.el7sat.noarch

I can see Provisioning template history after upgrade to satellite 6.3.2 2.0
Comment 22 errata-xmlrpc 2018-06-19 16:17:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1950

Note You need to log in before you can comment on or make changes to this bug.