Bug 155922 - dlm-kernel and dlm-kernel-smp requirement mismatch
dlm-kernel and dlm-kernel-smp requirement mismatch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dlm-kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
:
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2005-04-25 15:41 EDT by Jef Spaleta
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 19:14:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2005-04-25 15:41:51 EDT
Description of problem:
dlm-kernel-smp-2.6.11.2-20050420.131626.FC4.0
rpm -q --requires dlm-kernel-smp
/lib/modules/2.6.11-1.1253_FC4smp
kernel-smp = 2.6.11-1.1253_FC4

dlm-kernel-2.6.11.2-20050420.131626.FC4.0
rpm -q --requires dlm-kernel
cman-kernel >= 2.6.11
kernel = 2.6.11-1.1253_FC4

Consistency Questions:
should dlm-kernel-smp require cman-kernel-smp ?
should dlm-kernel require /lib/modules/2.6.11-1.1253_FC4 ?

Other issues:
since cman-kernel package will have to be provided in i586 and i686 varieties
for x86 systems since the kernel is provided as i586 and i686, is the
cman-kernel requirement enough to make sure the correct arch of cman-kernel is
available? If someone has both i586 and i686 kernels installed.. you can run
into a corner case where cman-kernel require is satified but with the wrong arch  .
Comment 1 Chris Feist 2005-04-25 16:41:01 EDT
I've fixed the above requires.  Both up & smp should require /lib/modules and
the appropriate cman-kernel.

Currently I'm only building i686.  How can I test which arch of a package is
installed?
Comment 2 Joe Orton 2005-04-26 08:54:39 EDT
Use e.g.:

  rpm -q --qf '%{name}-%{version}-%{release}.%{arch}\n' some-package

Any chance you can use a less obfuscated release field for these packages? 

-2.6.11.3-20050425.154843.FC4.0

is rather insanely long.
Comment 3 Joe Orton 2005-04-26 09:00:21 EDT
Err, or if you were asking how to test in a Requires field, I'm not sure.
Comment 4 Jef Spaleta 2005-04-26 09:16:59 EDT
(In reply to comment #1)
> Currently I'm only building i686.  How can I test which arch of a package is
> installed?

I'm not sure.  It's a corner case I don't think other 3rd party kernel module
packages have been able to address either. I was just hoping I could poke you
into a eureka moment.  It's something worth asking around about and seeing if
there is a technical solution available. The fedora-packaging mailinglist would
be a good place to bring it up to try to come up with a consistent technical
solution that red hat and 3rd party packagers can use. Maybe dag or ville have
comments with regard to testing for matching arch between kernel and
kernel-module package.

In any event, you are probably going to want to turn on i586 builds since the
kernel is still being built for i586 as well.
-jef
Comment 5 Chris Feist 2005-05-03 12:26:05 EDT
i586 kernel packages are now being built.

Note You need to log in before you can comment on or make changes to this bug.