Bug 1559325 - Should use apis group for webhook URL as CLI
Summary: Should use apis group for webhook URL as CLI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.10.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-22 09:58 UTC by shahan
Modified: 2018-07-30 19:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Different BC's webhook link obtained by Web Console and CLI, where the CLI used the the right 'build.openshift.io' api group but Web Console wasn't using any api group. Consequence: Wrong webhook URL was obtained by the Web Console Fix: Updated the Webhook filter to use the right 'build.openshift.io' api group Result: The Web Console now provides the right URL for the BC's Webhooks
Clone Of:
Environment:
Last Closed: 2018-07-30 19:10:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:11:27 UTC

Description shahan 2018-03-22 09:58:48 UTC
Description of problem:
 Should use apis group for webhook URL as CLI

Version-Release number of selected component (if applicable):
  OpenShift Master: v3.9.13 
  Kubernetes Master: v1.9.1+a0ce1bc657 
  OpenShift Web Console: v3.9.13 

How reproducible:
 Always

Steps to Reproduce:
1. oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/templates/ui/application-template-stibuild-without-customize-route.json
2. Login in web console, goto bc configuration tab and check URL for Generic/Github Webhook
3. Login in CLI, oc describe bc ruby-sample-build 

Actual results:
2.  webhook URL using oapi group via web:
https://<master>/oapi/v1/namespaces/hasha-pro1/buildconfigs/ruby-sample-build/webhooks/secret101/generic
3. webhook URL using apis group via CLI:
https://<master>/apis/build.openshift.io/v1/namespaces/hasha-pro1/buildconfigs/ruby-sample-build/webhooks/<secret>/github

Expected results:
Should use apis group for webhook URL as CLI

Additional info:

Comment 1 Jakub Hadvig 2018-03-23 15:41:28 UTC
Fixing PR: https://github.com/openshift/origin-web-console/pull/2911

Comment 3 shahan 2018-05-16 03:11:50 UTC
checked this issue as description, using /apis group for webhook url on web console, like this: https://<master>/apis/build.openshift.io/v1/namespaces/hasha-pro1/buildconfigs/musicstore/webhooks/5T5CV0ltUibxwB34Ik6MBVjhlhGKGwWA2IBfRHKo/github


OpenShift Master: v3.10.0-0.46.0 
Kubernetes Master: v1.10.0+b81c8f8 
OpenShift Web Console: v3.10.0-0.46.0

Comment 5 errata-xmlrpc 2018-07-30 19:10:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.