Bug 1559529 - qbs adds unneeded dependency on python2 to qt-creator
Summary: qbs adds unneeded dependency on python2 to qt-creator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qbs
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro Mani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: depchain
TreeView+ depends on / blocked
 
Reported: 2018-03-22 17:28 UTC by Matías Zúñiga
Modified: 2018-04-03 13:26 UTC (History)
1 user (show)

Fixed In Version: qbs-1.11.0-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-03 13:26:05 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Qt Bug Tracker QBS-1266 None None None 2018-03-22 17:28:55 UTC

Description Matías Zúñiga 2018-03-22 17:28:56 UTC
Description of problem:
The fedora qbs package adds python2 to the list of installed packages by qt-creator via qt-creator -> qbs -> python2.

The dependency on python2 is added automatically because of the presence of libraries needed by dmgbuild. However, according to the qt people, dmgbuild is not intended to be run outside MacOS [1]. Debian already removed the python code of qbs [2].

Version-Release number of selected component (if applicable): 1.9, 1.10, 1.11

Steps to Reproduce:
1. dnf install qt-creator, or dnf install qbs

Actual results:
Python2 is installed

Expected results:
Python2 is not pulled as a dependency, because the python code is meant to be used only in MacOS.

Additional info:
[1] https://bugreports.qt.io/browse/QBS-1266
[2] https://salsa.debian.org/qt-kde-team/qt/qbs/commit/60b7cfd553fb4a64959da8fd10bd8018ae8673e6

Comment 1 Fedora Update System 2018-03-24 19:59:29 UTC
qbs-1.11.0-0.4.git8e39638.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e00fd3ef38

Comment 2 Fedora Update System 2018-03-25 20:32:06 UTC
qbs-1.11.0-0.4.git8e39638.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e00fd3ef38

Comment 3 Fedora Update System 2018-03-26 08:59:14 UTC
qbs-1.11.0-0.5.git8e39638.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-206323b1b0

Comment 4 Fedora Update System 2018-03-26 15:02:00 UTC
qbs-1.11.0-0.5.git8e39638.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-206323b1b0

Comment 5 Fedora Update System 2018-03-28 22:41:48 UTC
qbs-1.11.0-1.fc28 qt-creator-4.6.0-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4fede53878

Comment 6 Fedora Update System 2018-03-29 13:57:17 UTC
qbs-1.11.0-1.fc28, qt-creator-4.6.0-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4fede53878

Comment 7 Fedora Update System 2018-04-03 13:26:05 UTC
qbs-1.11.0-1.fc28, qt-creator-4.6.0-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.