Bug 1559590 (CVE-2017-18234) - CVE-2017-18234 exempi: Use after free via a PDF file containing JPEG data
Summary: CVE-2017-18234 exempi: Use after free via a PDF file containing JPEG data
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2017-18234
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1559578 1559603 1656011
Blocks: 1633731
TreeView+ depends on / blocked
 
Reported: 2018-03-22 20:17 UTC by Laura Pardo
Modified: 2019-09-29 14:35 UTC (History)
4 users (show)

Fixed In Version: exempi 2.4.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 19:18:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:2048 None None None 2019-08-06 12:07:24 UTC

Description Laura Pardo 2018-03-22 20:17:17 UTC
An issue was discovered in Exempi before 2.4.3. It allows remote attackers to cause a denial of service (invalid memcpy with resultant use-after-free) or possibly have unspecified other impact via a .pdf file containing JPEG data, related to XMPFiles/source/FormatSupport/ReconcileTIFF.cpp, XMPFiles/source/FormatSupport/TIFF_MemoryReader.cpp, and XMPFiles/source/FormatSupport/TIFF_Support.hpp.


References:
https://bugs.freedesktop.org/show_bug.cgi?id=100397

Patch:
https://cgit.freedesktop.org/exempi/commit/?id=c26d5beb60a5a85f76259f50ed3e08c8169b0a0c

Comment 1 Laura Pardo 2018-03-22 20:56:04 UTC
Created exempi tracking bugs for this issue:

Affects: fedora-all [bug 1559578]

Comment 5 Adam Mariš 2018-12-04 13:04:32 UTC
Statement:

This issue affects the versions of exempi as shipped with Red Hat Enterprise Linux 6 and 7.

Red Hat Enterprise Linux 6 is now in Maintenance Support 2 Phase of the support and maintenance life cycle. This has been rated as having a security impact of Low, and is not currently planned to be addressed in future updates. For additional information, refer to the Red Hat Enterprise Linux Life Cycle: https://access.redhat.com/support/policy/updates/errata/.

Comment 7 errata-xmlrpc 2019-08-06 12:07:23 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2019:2048 https://access.redhat.com/errata/RHSA-2019:2048

Comment 8 Product Security DevOps Team 2019-08-06 19:18:34 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2017-18234


Note You need to log in before you can comment on or make changes to this bug.