Bug 1559606 - Cannot use mouse and keyboard after connecting to freerdp-shadow-cli
Summary: Cannot use mouse and keyboard after connecting to freerdp-shadow-cli
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freerdp
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simone Caronni
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-22 21:04 UTC by Iavael
Modified: 2018-11-06 23:58 UTC (History)
7 users (show)

Fixed In Version: freerdp-2.0.0-44.rc3.fc27 freerdp-2.0.0-44.rc3.fc28 freerdp-2.0.0-46.20181008git00af869.fc28 freerdp-2.0.0-46.20181008git00af869.fc29 freerdp-2.0.0-46.20181008git00af869.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 21:08:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Iavael 2018-03-22 21:04:40 UTC
Description of problem:
After connecting to freerdp-shadow-cli server it's not possible to use mouse and keyboard buttons in opened session because of disabled XTEST in rpm spec.

Version-Release number of selected component (if applicable):
2.0.0-40.20180320gitde83f4d

How reproducible:
Always

Steps to Reproduce:
1. Start freerdp-shadow-cli
2. Connect to server with xfreerdp
3. Try to use mouse or keyboard in opened session

Actual results:
No reaction to mouse buttons and keyboard actions

Expected results:
Proper reaction to mouse buttons and keyboard actions

Additional info:
Looks like problem occurs because of disabled XTEST extension on rpm spec. Changing -DWITH_XTEST=OFF to -DWITH_XTEST=ON solves the problem

Related bug on github: https://github.com/FreeRDP/FreeRDP/issues/3895

Comment 1 Fedora Update System 2018-04-09 08:56:03 UTC
remmina-1.2.0-0.51.20180408.git.6b62986.fc28 freerdp-2.0.0-41.20180405gita9ecd6a.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3a72df41cd

Comment 2 Fedora Update System 2018-04-09 08:56:46 UTC
remmina-1.2.0-0.51.20180408.git.6b62986.fc26 freerdp-2.0.0-41.20180405gita9ecd6a.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7de3c2872e

Comment 3 Fedora Update System 2018-04-09 08:57:28 UTC
remmina-1.2.0-0.51.20180408.git.6b62986.fc27 freerdp-2.0.0-41.20180405gita9ecd6a.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-92f978f8d3

Comment 4 Fedora Update System 2018-04-09 21:55:12 UTC
freerdp-2.0.0-41.20180405gita9ecd6a.fc28, remmina-1.2.0-0.51.20180408.git.6b62986.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3a72df41cd

Comment 5 Fedora Update System 2018-04-09 22:31:19 UTC
freerdp-2.0.0-41.20180405gita9ecd6a.fc26, remmina-1.2.0-0.51.20180408.git.6b62986.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7de3c2872e

Comment 6 Fedora Update System 2018-04-09 22:58:55 UTC
freerdp-2.0.0-41.20180405gita9ecd6a.fc27, remmina-1.2.0-0.51.20180408.git.6b62986.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-92f978f8d3

Comment 7 Fedora Update System 2018-04-15 02:36:08 UTC
freerdp-2.0.0-41.20180405gita9ecd6a.fc28, remmina-1.2.0-0.51.20180408.git.6b62986.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2018-04-15 14:45:23 UTC
freerdp-2.0.0-41.20180405gita9ecd6a.fc27, remmina-1.2.0-0.51.20180408.git.6b62986.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Iavael 2018-04-16 01:20:37 UTC
Still not fixed

Comment 10 Fedora Update System 2018-04-27 11:17:20 UTC
freerdp-2.0.0-41.20180405gita9ecd6a.fc26, remmina-1.2.0-0.51.20180408.git.6b62986.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Iavael 2018-08-19 21:29:10 UTC
Fix was not included in freerdp-2.0.0-41.20180405gita9ecd6a (it looks like this bug was added to changelog for nothing).

Can anyone add one build option to make things working, please?

Comment 12 Fedora Update System 2018-08-20 14:40:35 UTC
remmina-1.2.31.3-1.fc27 freerdp-2.0.0-44.rc3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1a5160a24d

Comment 13 Fedora Update System 2018-08-20 14:41:31 UTC
remmina-1.2.31.3-1.fc28 freerdp-2.0.0-44.rc3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1b66de68ac

Comment 14 Michael DePaulo 2018-08-21 00:26:46 UTC
Simone Carroni (negativo17) can you comment on why you disabled it?
https://src.fedoraproject.org/rpms/freerdp/c/a3a466399cf88d76dd0dd9381528a7450fcf4d89?branch=master

Comment 15 Fedora Update System 2018-08-22 00:33:21 UTC
freerdp-2.0.0-44.rc3.fc27, remmina-1.2.31.3-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1a5160a24d

Comment 16 Fedora Update System 2018-08-22 03:12:48 UTC
freerdp-2.0.0-44.rc3.fc28, remmina-1.2.31.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1b66de68ac

Comment 17 Fedora Update System 2018-08-23 09:45:39 UTC
freerdp-2.0.0-44.rc3.fc27, remmina-1.2.31.3-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Iavael 2018-08-23 10:33:21 UTC
Sigh... still not fixed. Read comments at bodhi and here please.

Comment 19 Fedora Update System 2018-08-23 10:33:30 UTC
freerdp-2.0.0-44.rc3.fc28, remmina-1.2.31.3-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Iavael 2018-08-23 10:44:35 UTC
Simone, could you also tell, why do you mark bug as resolved in new release without doing anything about it (you didn't even read anything here).
It really looks like you just marked all opened bugs as resolved in new release without looking at them. That's just insane!

Comment 21 Simone Caronni 2018-10-15 19:44:50 UTC
Very sorry, there are issues with the bugs not being reported to me, so I don't get notifications. The previous maintainer always said that he was no longer interested in maintaining the package but never bothered changing the admin contact.

Comment 22 Simone Caronni 2018-10-15 19:46:48 UTC
To be more precise, I have a filter on Bugzilla for this, otherwise I get lost in the thousand of emails I receive from the buildsystems and bugzilla.

Comment 23 Fedora Update System 2018-10-15 20:15:02 UTC
vinagre-3.22.0-11.fc28 remmina-1.2.32-1.fc28 freerdp-2.0.0-46.20181008git00af869.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-bd2645e89a

Comment 24 Fedora Update System 2018-10-15 20:15:35 UTC
vinagre-3.22.0-11.fc29 remmina-1.2.32-1.fc29 freerdp-2.0.0-46.20181008git00af869.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-19776d8267

Comment 25 Fedora Update System 2018-10-15 20:16:03 UTC
remmina-1.2.32-1.fc27 freerdp-2.0.0-46.20181008git00af869.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-869c8b1033

Comment 26 Fedora Update System 2018-10-16 11:57:27 UTC
freerdp-2.0.0-46.20181008git00af869.fc27, remmina-1.2.32-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-869c8b1033

Comment 27 Fedora Update System 2018-10-16 12:38:22 UTC
freerdp-2.0.0-46.20181008git00af869.fc28, remmina-1.2.32-1.fc28, vinagre-3.22.0-11.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-bd2645e89a

Comment 28 Fedora Update System 2018-10-16 15:52:01 UTC
freerdp-2.0.0-46.20181008git00af869.fc29, remmina-1.2.32-1.fc29, vinagre-3.22.0-11.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-19776d8267

Comment 29 Simone Caronni 2018-10-17 11:03:02 UTC
@iavael, I finally got the admin address change, I hope it does not happen again!

Comment 30 Iavael 2018-10-19 09:19:19 UTC
Thanks, Simone.

Comment 31 Fedora Update System 2018-10-23 21:08:21 UTC
freerdp-2.0.0-46.20181008git00af869.fc28, remmina-1.2.32-1.fc28, vinagre-3.22.0-11.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 32 Fedora Update System 2018-10-30 17:28:16 UTC
freerdp-2.0.0-46.20181008git00af869.fc29, remmina-1.2.32-1.fc29, vinagre-3.22.0-11.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2018-11-06 23:58:43 UTC
freerdp-2.0.0-46.20181008git00af869.fc27, remmina-1.2.32-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.