Bug 1559675 - Jenkins readinessProbe initialDelaySeconds: 3 is too short and spamming events
Summary: Jenkins readinessProbe initialDelaySeconds: 3 is too short and spamming events
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.9.z
Assignee: Gabe Montero
QA Contact: Dongbo Yan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-23 01:41 UTC by Takayoshi Kimura
Modified: 2018-06-21 17:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: resource constraints can lead to the readiness probe in the example jenkins templates readiness probes citing failure prematurely Consequence: jenkins deployments would fail unnecessarily Fix: the readiness probe was relaxed in the tempaltes Result: unnecessary jenkins deployment failures due to the aggressive readiness probe should decrease / go away
Clone Of:
Environment:
Last Closed: 2018-05-17 06:43:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:44:07 UTC

Description Takayoshi Kimura 2018-03-23 01:41:34 UTC
Description of problem:

Jenkins readinessProbe initialDelaySeconds: 3 is too short.

Jenkins is Java and it typically needs 60 sec for boot on 4 CPU cores machine. 3 sec is too short, spamming events with readiness probe failure messages and users get confused by these many failures.

I think initialDelaySeconds: 60  would be reasonable default.

The livenessProbe is configured with initialDelaySeconds: 420.

Version-Release number of selected component (if applicable):

v3.7

How reproducible:

Always

Steps to Reproduce:
1. oc new-app jenkins-ephemeral
2.
3.

Actual results:

Getting readiness probe failure 20 times at Jenkins boot

Expected results:

No or few readiness probe failure at Jenkins boot

Additional info:

Comment 1 Takayoshi Kimura 2018-03-23 01:46:40 UTC
Upstream pull req https://github.com/openshift/origin/pull/19072

Comment 2 Gabe Montero 2018-03-23 14:40:00 UTC
This got bumped in the 3.9 ansible installer version of the templates, and https://github.com/openshift/origin/pull/18900 is waiting for 3.9 to open back up  after GA.  Once that happens it will be in the subsequent 3.9 errata.

The template is already modified for this in the openshift/origin master branch.

There are no plans to update 3.7 openshift to backport these changes.

Comment 4 XiuJuan Wang 2018-04-17 03:07:29 UTC
Could access jenkins webconsole smoothly with ocp 3.9.20 which has included new updated jenkins template.

Comment 8 errata-xmlrpc 2018-05-17 06:43:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.