Bug 1559828 - [downstream clone - 4.1.10] "systemctl status lldpad.service" failed
[downstream clone - 4.1.10] "systemctl status lldpad.service" failed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor-ng (Show other bugs)
4.1.10
Unspecified Unspecified
unspecified Severity high
: ovirt-4.1.10
: ---
Assigned To: Yuval Turgeman
jiachen zhang
: Regression, ZStream
Depends On: 1555254
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-23 07:20 EDT by RHV Bugzilla Automation and Verification Bot
Modified: 2018-04-16 07:14 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1555254
Environment:
Last Closed: 2018-04-16 07:14:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 89212 master MERGED osupdater: also fix contexts on /dev 2018-03-23 07:21 EDT
oVirt gerrit 89349 ovirt-4.1 MERGED osupdater: also fix contexts on /dev 2018-03-23 07:21 EDT
oVirt gerrit 89350 ovirt-4.2 MERGED osupdater: also fix contexts on /dev 2018-03-23 07:21 EDT
Red Hat Product Errata RHBA-2018:1128 None None None 2018-04-16 07:14 EDT

  None (edit)
Description RHV Bugzilla Automation and Verification Bot 2018-03-23 07:20:32 EDT
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1555254 +++
======================================================================

Created attachment 1407890 [details]
/var/log /tmp

Description of problem:
After running the command "systemctl status lldpad.service", the service status is failed.

Version-Release number of selected component (if applicable):
RHVH-4.1-20180307.1-RHVH-x86_64-dvd1.iso

How reproducible:
100%

Steps to Reproduce:
1. Install RHVH-4.1-20180307.1-RHVH-x86_64-dvd1.iso, configure network successful.
2. Add RHVH to RHEV-M.
3. Check the service use "systemctl status lldpad.service".

Actual results:
1. After step 3, lldpad.service is failed.

Expected results:
1. After step 3, lldpad.service is active.

Additional info:
[root@dell-per730-34 ~]# systemctl status lldpad.service
● lldpad.service - Link Layer Discovery Protocol Agent Daemon.
   Loaded: loaded (/usr/lib/systemd/system/lldpad.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2018-03-14 16:47:01 CST; 15min ago
  Process: 19388 ExecStart=/usr/sbin/lldpad -t (code=exited, status=1/FAILURE)
 Main PID: 19388 (code=exited, status=1/FAILURE)

Mar 14 16:47:01 dell-per730-34.lab.eng.pek2.redhat.com systemd[1]: Started Link Layer Discovery Protocol.....
Mar 14 16:47:01 dell-per730-34.lab.eng.pek2.redhat.com systemd[1]: Starting Link Layer Discovery Protoco.....
Mar 14 16:47:01 dell-per730-34.lab.eng.pek2.redhat.com lldpad[19388]: error getting shm pid
Mar 14 16:47:01 dell-per730-34.lab.eng.pek2.redhat.com systemd[1]: lldpad.service: main process exited, ...RE
Mar 14 16:47:01 dell-per730-34.lab.eng.pek2.redhat.com systemd[1]: Unit lldpad.service entered failed state.
Mar 14 16:47:01 dell-per730-34.lab.eng.pek2.redhat.com systemd[1]: lldpad.service failed.

No such issue on redhat-virtualization-host-4.1-20180313.0 (based on 74)

# imgbase w 
You are on rhvh-4.1-0.20180313.0+1
[root@localhost /]# systemctl status lldpad.service
● lldpad.service - Link Layer Discovery Protocol Agent Daemon.
   Loaded: loaded (/usr/lib/systemd/system/lldpad.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-03-14 04:13:55 EDT; 59min ago
 Main PID: 29746 (lldpad)
   CGroup: /system.slice/lldpad.service
           └─29746 /usr/sbin/lldpad -t

Mar 14 04:13:55 localhost.localdomain systemd[1]: Started Link Layer Discovery Protocol Agent Daemon..
Mar 14 04:13:55 localhost.localdomain systemd[1]: Starting Link Layer Discovery Protocol Agent Daemon....

(Originally by Jiachen Zhang)
Comment 1 RHV Bugzilla Automation and Verification Bot 2018-03-23 07:20:41 EDT
Consider this is a regression bug from RHVH 74 to RHVH 75.

(Originally by Chen Shao)
Comment 3 RHV Bugzilla Automation and Verification Bot 2018-03-23 07:20:45 EDT
How can this be a regression given https://bugzilla.redhat.com/show_bug.cgi?id=1555257 ?

(Originally by Ryan Barry)
Comment 5 RHV Bugzilla Automation and Verification Bot 2018-03-23 07:20:56 EDT
(In reply to Ryan Barry from comment #2)
> How can this be a regression given
> https://bugzilla.redhat.com/show_bug.cgi?id=1555257 ?

Try to test on previous version redhat-virtualization-host-4.1-20180126.0 (4.1.9 ASYNC), can't reproduce this issue, so give regression keywords.

# imgbase w 
You are on rhvh-4.1-0.20180126.0+1
# 
# systemctl status lldpad.service
● lldpad.service - Link Layer Discovery Protocol Agent Daemon.
   Loaded: loaded (/usr/lib/systemd/system/lldpad.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-03-14 23:21:45 EDT; 1min 2s ago
 Main PID: 1556 (lldpad)
   CGroup: /system.slice/lldpad.service
           └─1556 /usr/sbin/lldpad -t

Mar 14 23:21:45 dhcp-8-111.nay.redhat.com systemd[1]: Started Link Layer Discovery Protocol Agent Daemon..
Mar 14 23:21:45 dhcp-8-111.nay.redhat.com systemd[1]: Starting Link Layer Discovery Protocol Agent Daemon....

(Originally by Chen Shao)
Comment 8 jiachen zhang 2018-04-03 06:11:23 EDT
I tested this bug with these version: 
redhat-virtualization-host-4.1-20180329.0
redhat-release-virtualization-host-4.1-10.4.el7.x86_64 
imgbased-0.9.56-0.1.el7ev.noarch. 

However, the lldpad.service is still failed. I want to know whether this problem has been fixed?
Comment 9 Ryan Barry 2018-04-03 06:50:35 EDT
There was a patch for this in the last build, but the service may not have been enabled -- swapping back to 7.5 required some juggling of the release file

Can you post the status of audit2allow -a and systemctl status imgbase-relabel-dev.service?
Comment 10 Ryan Barry 2018-04-03 08:11:38 EDT
I double-checked this, and the service was not enabled when we swapped back to 7.5. It will be enabled in the next 7.5 build
Comment 11 jiachen zhang 2018-04-04 03:05:51 EDT
I test the bug with the version: redhat-virtualization-host-4.1-20180403.1
and the lldpad.service is active(running) after I add rhvh to rhvm. So the bug has been fixed successfully. I will changed the status to VERIFIED.
Comment 14 errata-xmlrpc 2018-04-16 07:14:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1128

Note You need to log in before you can comment on or make changes to this bug.