This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 156 - setsysfont chooses wrong font
setsysfont chooses wrong font
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
: 374 491 903 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-22 13:48 EST by stone
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-02-05 12:55:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description stone 1998-11-22 13:48:38 EST
If vga=extended is specified in lilo.conf to get
50 line console, the setsysfont call in rc.sysinit
switches back to 25 by loading a 8x16 font.
Comment 1 Bill Nottingham 1998-12-15 17:48:59 EST
*** Bug 156 has been marked as a duplicate of this bug. ***
When booting my RH 5.2 system with the parameter
vga=ask
in /etc/lilo.conf and selecting a video mode other than
25x80 {eg 50x80}, the display reverts to 25x80 mode when
inetd starts in the bootup process.
Even setting
vga=1
in /etc/lilo.conf has the same problem - as soon as inetd
starts, the display returns to 25x80 mode.
Comment 2 Bill Nottingham 1998-12-15 17:57:59 EST
*** Bug 156 has been marked as a duplicate of this bug. ***
When I boot with vga=extended, the screen starts out in
80x50, then around when the system is mounting the DOS
partition, the screen goes to 80x25.  Not good for a 19"
or 21" monitor.

Is this a problem with /sbin/setsysfont?

I'm not certain where the problem is.  Only with 5.2, not
previous versions.

------- Additional Comments From jturner@redhat.com  12/10/98 10:19 -------
Sure enough, right after the mounting of the local filesystems, the
screen returns to 80x25 mode.
Comment 3 Steve Wills 1998-12-17 10:51:59 EST
setsysfont is just a shell script to call /usr/sbin/setfont.
From the setfont man page:

       As currently there is no mode  switching  support  in  the
       Linux  kernel,  setfont has nothing to do with the current
       EGA/VGA mode. It's totally user's responsibility to choose
       a font matching the current video mode.

However, running "stty -a" will tell you the number of lines and
collumns used. Couldn't this be used to try to guess the correct thing
to do?

We have seen questions about this in support and verifed it here as
well.
Comment 4 Bill Nottingham 1998-12-21 10:34:59 EST
*** Bug 156 has been marked as a duplicate of this bug. ***

When I change the screen-mode at boot-up by adding the line:

vga=ext

to /etc/lilo.conf the screenmode gets initialized correctly
but jumps back to normal after init starts.

byez tomazu
Comment 5 Jeff Johnson 1999-01-26 10:08:59 EST
*** Bug 903 has been marked as a duplicate of this bug. ***

On a fresh RedHat 5.2 install, if the user edits lilo.conf
so that there is a global vga=2 rule and then runs lilo, the
VGA mode will be set to 50 lines per screen.

But in the /etc/rc.d/rc.sysinit script, the block that calls
setsysfont will kick the VGA mode back to 25 lines per
screen.

That wasn't a problem in earlier RedHat releases.

------- Additional Comments From dkl@redhat.com  01/20/99 18:33 -------
I have verified this to be a problem on a test machine. I added vga=2
to the global settings in lilo.conf and upon rebooting the fonts
changed to the smaller size. The when setsysfont is encountered in the
rc.sysinit the font size is set back up to the default size. It also
exhibits similar behaviour with the ther bga= settings possible.

------- Additional Comments From dkl@redhat.com  01/20/99 18:33 -------
I have verified this to be a problem on a test machine. I added vga=2
to the global settings in lilo.conf and upon rebooting the fonts
changed to the smaller size. The when setsysfont is encountered in the
rc.sysinit the font size is set back up to the default size. It also
exhibits similar behaviour with the ther bga= settings possible.

------- Additional Comments From ayn2@cornell.edu  01/25/99 22:13 -------
This is a duplicate of #156

------- Additional Comments From ayn2@cornell.edu  01/25/99 22:13 -------
This is a duplicate of #156
Comment 6 Bill Nottingham 1999-02-05 12:55:59 EST
this should be fixed in initscripts-3.84; setfont is called
only if a specific font is specified by the user.

Note You need to log in before you can comment on or make changes to this bug.