Bug 156007 - Java Script debugger crash Mozilla (latest update: 1.7.7-1.3.1)
Java Script debugger crash Mozilla (latest update: 1.7.7-1.3.1)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-26 12:15 EDT by William Lovaton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 19:05:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
from gdb (4.26 KB, text/plain)
2005-04-26 12:24 EDT, William Lovaton
no flags Details

  None (edit)
Description William Lovaton 2005-04-26 12:15:55 EDT
I use Fedora Core 3 with the latest official updates in my office's workstation.
 The last yum update of Mozilla (1.7.7-1.3.1) crash when launching the
JavaScript debugger.

To reproduce, just start mozilla, select Tools -> Web Development -> Java Script
Debugger.  Mozilla crashes the second after the debugger is shown.

I have the following mozilla packages:
mozilla-nss-1.7.7-1.3.1
mozilla-nspr-1.7.7-1.3.1
mozilla-1.7.7-1.3.1
mozilla-js-debugger-1.7.7-1.3.1

To date, the only pending updates are, according to yum check-update, the following:
ImageMagick.i386                        6.2.2.0-1.fc3          updates-released
dia.i386                                1:0.94-5.fc3           updates-released
kdegames.i386                           6:3.3.1-1              updates-released
logwatch.noarch                         5.2.2-1.FC3.1          updates-released
net-snmp.i386                           5.2.1-10.FC3           updates-released
net-snmp-libs.i386                      5.2.1-10.FC3           updates-released

I'll post a backtrace later.
Comment 1 William Lovaton 2005-04-26 12:24:14 EDT
Created attachment 113675 [details]
from gdb

I know that backtraces on stripped binaries are kind of useless but anyway...

To get mozilla running with gdb I exported LD_PRELOAD=
/usr/lib/mozilla-1.7.7/libmozjs.so and that was all.  The rest is in the
attachment.
Comment 2 William Lovaton 2006-01-06 19:05:56 EST
Very old bug... it now works with the latest version for FC3

Note You need to log in before you can comment on or make changes to this bug.