Bug 1560102 - openvswitch service is not enabled on the overcloud image
Summary: openvswitch service is not enabled on the overcloud image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Alex Schultz
QA Contact: Artem Hrechanychenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-23 21:44 UTC by Alex Schultz
Modified: 2018-08-03 18:32 UTC (History)
3 users (show)

Fixed In Version: openstack-tripleo-common-8.5.1-0.20180304032203.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:48:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1757111 None None None 2018-03-23 21:44:27 UTC
OpenStack gerrit 555791 None None None 2018-03-23 21:46:18 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:48:48 UTC

Description Alex Schultz 2018-03-23 21:44:27 UTC
A change upstream to switch os-net-config to be installed via a package rather than via a DIB element accidently removed the openvswitch element that enables the openvswitch service by default on the overcloud. Prior to upstream Queens, the service was enabled so this was a regression.

Comment 5 Artem Hrechanychenko 2018-04-02 13:37:59 UTC
VERIFIED

guestfish -a /var/lib/libvirt/images/overcloud-full.qcow2 run : mount /dev/sda / : find /etc/systemd/system > master.txt

[root@sealusa9 ~]# cat master.txt |grep switch
/multi-user.target.wants/openvswitch.service


 virt-customize -a /var/lib/libvirt/images/overcloud-full.qcow2 --run-command "rpm -qa "*openvswitch*" > /root/file2"


[root@sealusa9 mnt]# cat /mnt/root/file2
openvswitch-ovn-central-2.9.0-15.el7fdp.x86_64
openvswitch-ovn-common-2.9.0-15.el7fdp.x86_64
openvswitch-2.9.0-15.el7fdp.x86_64
python-openvswitch-2.9.0-15.el7fdp.noarch
openvswitch-ovn-host-2.9.0-15.el7fdp.x86_64
openstack-neutron-openvswitch-12.0.1-0.20180327195360.68b8980.el7ost.noarch

Comment 9 errata-xmlrpc 2018-06-27 13:48:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.