Bug 1560290 - autofs fails to find IPA-stored maps if sssd cache is cleaned out
Summary: autofs fails to find IPA-stored maps if sssd cache is cleaned out
Keywords:
Status: CLOSED DUPLICATE of bug 1648521
Alias: None
Product: Fedora
Classification: Fedora
Component: sssd
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Hrozek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-25 17:16 UTC by James
Modified: 2018-12-18 23:33 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-18 23:33:18 UTC
Type: Bug


Attachments (Terms of Use)

Description James 2018-03-25 17:16:27 UTC
Description of problem:
I have workstations configured to find their automount maps via sssd on a FreeIPA installation (configured using ipa-client-automount).

* If I clean out the sssd cache and reboot (I discovered this after changing the keytab on a machine), the autofs maps aren't found.

* If I restart autofs, it picks up the mounts and things work. This could indicate it's a network timing issue.

* On subsequent boots the maps are there, presumably because sssd has cached them.

Version-Release number of selected component (if applicable):
sssd-1.16.1-1.fc27.x86_64
autofs-5.1.4-6.fc27.x86_64

How reproducible:
Consistently

Steps to Reproduce:
1. systemctl stop sssd
2. rm /var/lib/sss/db/*
3. systemctl reboot

Actual results:
autofs-managed mount points empty

Expected results:
autofs-managed mount points found and activated properly.

Comment 1 James 2018-12-18 23:33:18 UTC
Actually bug 1648521.

*** This bug has been marked as a duplicate of bug 1648521 ***


Note You need to log in before you can comment on or make changes to this bug.