Bug 15603 - more fun with neomagic x configuration
Summary: more fun with neomagic x configuration
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard: Winston gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-07 06:05 UTC by Jeremy Katz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-19 19:35:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2000-08-07 06:05:43 UTC
Anaconda still isn't quite doing the right thing in the GUI install with
the Neomagic NM2160 which is in at least some of the Vaio 505 subnotes. 
During the install process, it detects as having only 256k of ram as
opposed to 2.5 megs -- changed to 2 megs.  Default X server pointed to is
the XFree 3.3.6 server, but the 4.x server has worked pretty well for me
throughout the beta thus far, and it's config file works right out of the
installer.  The 3.3.6 config file isn't in such good shape :(  The best
resolution of this imo is to point to the XFree4 server by default, but if
there have been some problems with neomagic chips on XFree 4, the following
probably need to be looked at

/etc/X11/XF86Config is created with a DefaultColorDepth of 32bpp, which the
amount of ram present can't ahndle at the highest resolution of 800x600. 
After changing the default depth to 16bpp, still only 640x480 is supported
because the ranges given when selecting Generic 800x600 LCD panel don't
encompass any of the 800x600 modelines.  Simply changing the VertRefresh to
be within the range of 60-65 instead of only 60 takes care of this (I've
seen this one in the past on mine and other laptops and this fix seems to
fix it across the board)

Even if a 4.0 server is used by default with the NM, I still think the
default 800x600 LCD panel modes for 3.3.6 are a little wacky and could hit
people using other chipsets that hit the XFree 3.3.6 path.

Comment 1 Glen Foster 2000-08-07 17:47:26 UTC
This defect is considered MUST-FIX for Winston Gold-release

Comment 2 Bill Nottingham 2000-08-16 02:21:12 UTC
Is this improved any in RC1?

Comment 3 Jeremy Katz 2000-08-16 15:13:30 UTC
To be honest, I can't say -- RC1 came out right before I left for Linux World
Expo and as the box is the only machine I have to check my email with while I'm
out here and I've got no CD drive (forgot the CDs anyway.. *doh*) and the
network connection to the show is saturated, I'm a little reluctant to try and
test this until I get back to Raleigh on Friday...  but, I will test it once I
get back to Raleigh Friday night

Comment 4 Jeremy Katz 2000-08-19 15:08:02 UTC
Default modes allowed for 800x600 LCD panel are a lot better in RC1. 
Unfortunately, anaconda is  still putting 'DefaultColorDepth 32' in the 3.3.6
config file and using 3.3.6 by default which just doesn't work at all with the
amount of RAM the chip has

Comment 5 Trond Eivind Glomsrxd 2000-08-19 19:22:20 UTC
Note that "256 kB" of detected memory means that detection didn't succeed.

Comment 6 Trond Eivind Glomsrxd 2000-08-19 19:35:07 UTC
We're switching to XFree4 for neomagic now...

Comment 7 Jeremy Katz 2000-08-22 04:52:21 UTC
Looks good in RC2.  My laptop now actually installs and starts X without my
doing any tweaking of config files post-install which is nice :)


Note You need to log in before you can comment on or make changes to this bug.