Bug 156035 - Autofs uses local /etc file map in preference to NIS if one exists
Autofs uses local /etc file map in preference to NIS if one exists
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
RHEL3U7NAK
:
Depends On:
Blocks: RHEL3U8CanFix
  Show dependency treegraph
 
Reported: 2005-04-26 15:58 EDT by Paul Waterman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006-0459
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 10:43:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Waterman 2005-04-26 15:58:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414

Description of problem:
The autofs RPM included in RHEL 3.0 U5 beta (autofs-4.1.3-104) will use a local /etc file map in preference to NIS if one exists, regardless of /etc/nsswitch.conf settings or the configuration of the master map.

Version-Release number of selected component (if applicable):
autofs-4.1.3-104

How reproducible:
Always

Steps to Reproduce:
1. Create an auto.master map (NIS or /etc/auto.master) with an entry for an NIS map. E.g.,

/home auto_home -rw,nosuid,nobrowse,intr

2. Create a file in /etc with the same name as the NIS map. E.g.,

/etc/auto_home

3. Start autofs (service autofs start).

4. Run ps to verify that the automounter is using the /etc map when it should be using the NIS map:

% ps -auxww | fgrep auto_home
root     12687  1.2  0.0  1844  844 tty1     S    14:50   0:00 /usr/sbin/automount --timeout=60 /home file /etc/auto_home -rw,nosuid,nobrowse,intr

Note that it will use the /etc map regardless of the settings in /etc/nsswitch.conf.

Actual Results:  The automount executable uses the /etc file map.

Expected Results:  The automount executable should use the NIS map.

Additional info:

This may cause unexpected failures for users when they upgrade to U5 if they happen to have old map files sitting in /etc that they expect the automounter to ignore.
Comment 1 Jeffrey Moyer 2005-04-26 18:18:37 EDT
The logic in the init script does not appear to have changed.  How is this a
change in behaviour from U4?

Thanks. 
Comment 2 Jeffrey Moyer 2005-04-26 18:26:37 EDT
I just answered my own question.  Before if a map name was not an absolute path,
you would just look for it in the current working directory.  This was reported
as a bug, and we fixed this by attempting to read it from /etc.  Now, because of
this, a failure to find a file map results in success, whereas before you would
fall through to the yp case.

This is tricky.  Fix one bug, and you break things for others.  The only way to
make everybody happy is to do this the right way (by consulting
/etc/nsswitch.conf).  For U5, however, this isn't in the cards.  I will attempt
to put this logic after the yp case.
Comment 3 Paul Waterman 2005-05-26 18:54:42 EDT
The specific behaviour described in this bug is fixed in autofs-4.1.3-130 as
officially released in RHEL 3.0 U5. 

Therefore, this bug should probably be closed.
Comment 4 Paul Waterman 2005-05-26 19:00:31 EDT
Whoops. Never mind. Somebody re-imaged my U5 test machine back to U4. This
problem DOES still exist in autofs-4.1.3-130 -- drop a file in /etc with the
same name as an NIS automount map and watch it override the NIS map.
Comment 5 Jeffrey Moyer 2005-06-08 13:07:02 EDT
Paul, I think this is a dup of your bug 145152.  However, I am going to leave
this bug open, since it documents a regression that has not been addresses in
U5.  If this is really causing you pain, please let me know.  Otherwise, I'm
going to work on the proper fix for this problem for Update 6.

Thanks.
Comment 10 Jeffrey Moyer 2005-10-19 15:47:27 EDT
Same basic bug as 145152.  Deferring work.
Comment 13 Bob Johnson 2006-04-11 12:30:45 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 3.8 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 3.8 release.
Comment 14 Jeffrey Moyer 2006-05-02 09:45:36 EDT
A fix for this issue has just been committed to the RHEL 3 U8 pool.  It will be
available in autofs versions 4.1.3-178 and later.
Comment 17 Red Hat Bugzilla 2006-07-20 10:43:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0459.html

Note You need to log in before you can comment on or make changes to this bug.